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1  Introduction 

Welcome to FINALE Fireworks, a visual simulation and choreography program that lets you create and 

control a complete fireworks display. The program can be used by fireworks professionals and amateurs who 

are designing real-world fireworks shows, as well as by enthusiasts and artists working in the virtual world. 

FINALE Fireworks provides a simple and intuitive interface that lets you build a performance by dragging-

and-dropping individual shells onto a òSky Fieldó canvas. You can add and synchronize music, insert a 

background that depicts an actual shoot site, capture your creation as a òfiring scriptó (indispensible for the 

real-world designer), and even record a video that you can share with your friends.  

The graphical engine that creates the fireworks simulation in FINALE fireworks doesnõt use pre-rendered 

images or simple òwireframeó outlines. All of the shots youõll see when you play your show are created in real-

time, based on the physical properties of the mortars, shells, and other components that professionals use 

when designing an eventñwith just enough natural randomness to make each performance a unique 

experience. 

The first few chapters of this User Guide tells you everything you need to know to create a fireworks show 

with FINALE Fireworks. The final chapters explain how to create your own firework effects. 

Logging In 

The first thing you have to do, of course, is download the FINALE Fireworks software. If youõre reading this, 

youõre probably already running the program, but just in case, you can find the latest version of the program 

at the FINALE Fireworks website: 

http://www.finalefireworks.com/ 

The Website will step you through the process of creating an account and will download the latest version of 

the program. If youõve accepted the default installation location, youõll be able to launch FINALE Fireworks 

by double-clicking... 

C: \ Program Files \ FINALE Fireworks \ FINALE Fireworks.bat  

After launching the program, youõll see the login panel: 

 

http://www.finalefireworks.com/
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The only wrinkle, here, is that you must be connected to the Internet so the program can download the latest 

fireworks catalog. If you see the òNetwork error: communication failureó message when you log iné 

 

écheck your Internet connection. 
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2  User Interface Layout 

In this chapter weõll look at the general layout of the FINALE Fireworks user interface. Except for a couple 

simple editing windows, everything you need to create a fireworks show is presented in a single workspace. 

The illustration, below, points out the principal components of the workspace: 

 

 

 

 

 

Main Menu 

Sky Field 

Inventory 

Timeline 

Playhead 

Playback Controls 

Wind slider 

Zoom slider 
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In subsequent chapters, weõll take a closer look at most of these components. Briefly, they are: 

· Main Menu. The options in the Main Menu let you open and save shows, switch backgrounds, create 

òLaunch Positionsó, add music to your show, and so on. For real-world designers, the File submenu lets 

you write your show as a firing report in a number of standard formats. 

· Inventory. The Inventory section lists the fireworks that you can drop into your show. Every time you 

launch program, the application connects to the FINALE Fireworks website and downloads fireworks 

into your Inventory, so your fireworks list will always be up-to-date.  

· Sky Field. This is where your show is displayed. You can drag-and-drop fireworks into the Sky Field, move 

their launch and òtargetó positions (the target is the fireworkõs highest point), delete individual or groups 

of fireworks, and so on. 

· Wind Slider. FINALE can add a wind effect to your show. You increase and decrease the wind (and 

change its direction) by moving the Wind Slider up and down. As you move the slider, the speed and 

direction of the wind is displayed above the Wind icon. To remove all wind, move the slider to the 

vertical center of the window. 

· Zoom Slider. When you launch FINALE Fireworks, the Sky Field is set to simulate an area thatõs about 900 

feet high and 2000 feet wide. If you resize the window, the resolution changesñyour fireworks will 

appear to be closer or farther awayñbut the dimensions of the simulated area donõt change. To zoom in 

and out of the Sky Field, move the Zoom Slider up and down. The simulated height is displayed above 

the icon as you move the slider. 

· Timeline. The Timeline shows the temporal positions of your fireworks. In the illustration, we see three 

fireworks, represented by the white òblipsó along the Timeline. Exactly which part of the firework a blip 

represents depends on the type of firework: For shells, itõs the burst event; for fountains, comets, and 

mines, itõs the launch. If you look closely, you can see a wavy black section superimposed on the Timeline. 

This is the waveform of the music that youõve added to your show, making it easy to synchronize your 

show to your soundtrack. 

· The Playhead represents the current moment thatõs being displayed in the Sky Field, and moves left-to-

right as you play your show. You can drag the Playhead to quickly òscrubó through your show.  

· Playback Controls. The Playback Controls that are displayed onscreen let you start and pause your show, 

and rewind to the beginning. A number of other controls (incremental fast forward and rewind, seek to 

end, and so on) are provided in the File > Timeline submenu. All of the controls, onscreen or not, are 

bound to keyboard keys making it easy to control your show. Most notably, the spacebar toggles between 

Play and Pause, and arrow-left/arrow-right moves a paused show forwards and backwards by a single 

frame. 
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Other Views 

In addition to the default workspace, FINALE presents two other important views: The Firework Editor and 

the Firing View. 

· The Firework Editor presents a set of sliders, menus, and other controls that let you modify the attributes 

of a firework. To display the Firework Editor, you double-click on a firework that youõve added to your 

show. The editor is presented as a series of tabs across the top of the main window: 

 

The Firework Editor is described in detail starting with the Creating Your Own Fireworks chapter of this User 

Guide. 

Firework Editor 
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· The Firing View is a list of the fireworks that youõve added to your show, in chronological order. To bring 

up the Firing View, choose File > Firing View or type CONTROL-F: 

 

The Firing View is described in the Real-World Show Design chapter in this book. 

 

Firing View 
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3  Working with Fireworks 

In this chapter, weõll look at how you choose a firework and add it to your show. Weõll also look at how you 

select, place, modify, and delete fireworks. 

The Inventory 

The Inventory section of the UI contains all the fireworks that you can add to your show. When you log in, 

the program forms a connection to the FINALE Fireworks website and downloads the latest set of fireworks, 

including the fireworks that youõve designed and those that youõve selected from other FINALE users. 

Firework Categories 

There are a number of ways you can search for a firework. First, you can search by category. There are six 

firework categories, represented by the six tabs that run across the top of the Inventory: 

 

The Inventory provides a UI that lets you search within a category based on collection, subcategory, color, 

and mortar caliber: 

 

· The subcategories provide a further categorization of the fireworks type. Currently, only the Shells and 

Candle types have subcategories.  

· You can choose from three collection options: Standard fireworks is the set thatõs provided by FINALE; 

My fireworks are the effects that youõve created or have selected from other users; All collections is a 

combination of the two. 

Firework Categories 

Firework Subcategories Color Caliber Collection 
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· The color dropdown menu applies to all fireworks types. It lets you search for a firework that paints a 

particular color, whether in its tail or its burst. Many fireworks have more than one color. 

· The caliber dropdown also applies to all types. The larger the caliber, the bigger (and higher) the firework. 

Expanding your Inventory 

You can add fireworks to your inventory through the Edit > Add new fireworks option. This will bring up the 

Add Fireworks window: 

 

To add a firework, click the corresponding copy link. The firework will be add to your My fireworks collection.  

To delete a firework from your My fireworks collection, go to Edit > Manage my fireworks. A panel similar to the 

one above will appear that lets you remove individual effects. 

Adding a Firework to Your Show 

After youõve found the firework that you want, itõs time to add it to the show. There are two ways to add a 

firework:  

· By clicking on its icon in the Inventory. 

· By dragging and dropping the icon into the Sky Field. 

The difference between these two methods is the way in which the firework is placed in the scene, as 

described in the following sections. 
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Click to Add 

When you click an icon, the firework is dropped into the scene with its launch point set just above the launch 

caret that sits on the imaginary launch line, and its height (or target point) is defined by its caliber. Here, weõve 

clicked on the 5ó Red Ext Comet: 

 

You can drag the launch point after youõve dropped it, but only horizontally. You canõt drag a launch point up 

into the Sky Fieldñit always lies on the launch line at the bottom of the Sky Field. When you drag a 

fireworkõs launch point, the launch caret goes with it. The next firework you click-to-add will drop into 

thisnew location. (Note that you canõt move the launch caret by hand.) 

Notice that the fireworkõs trajectory is outlined with white dots. The white dots mean that the firework is 

selected. If we add another comet the first object becomes unselected, as indicated by the red dots (you have 

to hover the mouse over the Sky Field to see the unselected outline): 

Click here 

Height determined 
by caliber Launch point above 

the launch caret 

Launch line 

Target point 
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The second firework is added at the same position as the first, above the launch caret. The angle of the 

trajectory, however, is varied so that the two fireworks donõt lie on top of each other. The amount of 

variation depends on the fireworkõs definition. 

You can select a firework by clicking anywhere along its trajectory. Weõll talk more about selection when we 

get to the Modifying a Firework section. 

Drag and Drop 

When you drag and drop an icon, you get to control the fireworkõs launch point and its height (if youõre a 

real-world designer, this probably isnõt what you wantñsee the Note for the Real-World Designer, below). As you 

drag the icon out of the Inventory, the launch caret follows the mouse. When you drop the icon, the 

fireworkõs launch point drops to the caret, and its target point is wherever you let go of the mouse. However, 

this is only true for shells and comets; for the other firework types, the height is always controlled by the 

caliber of the mortar (you can adjust it by hand, later). 

The illustrations, below, show the caret as we drag a shell, and the placement of the launch and target points 

when we drop. (Note that the icon itself doesnõt actually appear under the mouse as you drag it.) 

Unselected Selected 



Working with Fireworks  FINALE Fireworks User Guide 

 PAGE 19 

 

Note for the Real-World Designer: Obeying the Caliber 

If youõre choreographing a real-world show, you want the physics of the fireworks to obey the caliber of the 

mortarñwhen you drag-and-drop an object, you donõt want the drop point to define the placement of the 

target point. To place the firework so its target point is placed according to the fireworkõs caliber, press the 

SHIFT key before you drop. 

Deleting Fireworks 

To delete a firework, you first must select it and then hit the DELETE key (not the BACKSPACE key). You can also 

delete a firework by selecting it and choosing the Edit > Delete option.  

If you want to delete all the fireworks in your show, choose the Edit > Select All option and hit DELETE (or 

choose Edit > Delete). 

Height and launch point 
are determined by the 

position of the drop 

Drag 

Caret moves 
with the drag 

Drop 
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4  Launch Positions: The Basics 

Rather than drop you fireworks randomly along the launch line, you can add them to specific launch positions. 

A launch position is a pre-defined location along the launch line that acts as a òmagnetic cradleó for the 

fireworks that you add into the scene. If you reposition the launch position, all of the fireworks that have 

been added to it move as a group. 

If youõre a real-world designer youõll probably use launch positions exclusively (as opposed to dropping 

fireworks into undefined locations on the launch line). Moreover, youõll probably define all of your launch 

positions first, before you start adding fireworks.  

This chapter looks at the basic elements of launch positions. A later chapter, Real-World Show Design looks at 

move advanced topics, such as how to use launch positions to assign modules and firing pins. 

Creating a Launch Position 

To create a launch position, select the Edit > Add launch position menu item: 

 

A launch position marker will appear in the center of the launch line: 

 

If we zoom in on the marker, we see a caret sitting in the òcradleó. This means that the launch position is 

selected. Hereõs a selected an unselected launch position: 

Launch position marker 



Launch Positions: The Basics  FINALE Fireworks User Guide 

 PAGE 21 

 

When you click an icon in the firework Inventory, the firework is automatically added to the currently-

selected launch position.  

You can also add a firework to a launch position by dragging the firework near the launch position marker. 

As you drag the firework near the marker, the fireworkõs launch point caret òsnaps toó the launch position 

marker (thatõs the òmagneticó aspect). When you drop, the fireworkõs launch point falls into the launch 

position, and its height is determined by the fireworkõs caliber: 

 

When you drag a launch position, the fireworks that it cradles move with it. 

Deleting Fireworks and Launch Positions 

To delete a launch position, hover the mouse over it (it will òlight upó), hold down the CONTROL key, and 

right-click. Launch positions arenõt affected by the Edit > Delete menu item.  

When you delete a launch position, the fireworks it contains remain on the screen.

Selected Unselected 
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5  Adding Fireworks in Time 

So far, weõve only discussed how to add a firework in space along the launch line. A fireworkõs position in 

time is just as important. The rule for adding a firework in time is simple: Itõs placed at the current position of 

the Playhead. However, thereõs a wrinkle, here:  

· For shells, the event thatõs dropped onto the Playhead (when the shell is added) is the burst. 

· For all other fireworks, itõs the launch. 

In the UI Layout chapter, we mentioned that a firework is represented as a blip on the Timeline. Thereõs 

actually more to it than that. If we zoom into the Timeline, youõll see that the blip leaves a trail. When we add 

a shell, the trail looks like this: 

 

The blip (the burst, for a shell) is aligned with the Playhead. The trail leading up to the blip shows the 

duration of the launch; the trail to the right is the fall off. 

For comets, fountains, and mines, the burst (essentially) coincides with the launch point: 

 

Adding Fireworks as the Playhead Is Moving 

Our simple rule of adding a firework at the Playhead doesnõt mean that the Playhead has to be sitting still. 

Another nice feature of FINALE Fireworks is that you can start the Playhead moving and add fireworks as it 

travels along the Timeline.  

To add a firework while the Playhead is moving, you use the same methods that were previously described: 

Click a firework icon, or drag-and-drop the icon into the Sky Field. By default, the fireworkõs òlaunch 

momentó is added to the sceneñwhen you click or drop, the firework is added and immediately launched. In 

some cases, this might not be what you want. Most notably, if youõre adding fireworks as you play your show 

in order to coordinate bursts with specific moments in your soundtrack, you donõt want the fireworks to be 
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added at their launch moments, you want a òclick-means-burstó effect. To do this, hold down the SHIFT key 

when you click (or drop). The firework will be added at its òburst momentó.  

Modifying a Firework 

You can modify a firework youõve placed in the scene byé 

· moving its launch point, 

· bending or stretching its target point, 

· and moving it in time. 

All three modifications are performed by grabbing some part of the firework and dragging the mouse. But 

before you do any of this, you have to select the firework. 

Making a Selection 

To select a firework, you simply click anywhere along its trail in the Sky Field or on its blip on the Timeline. 

As you hover over the firework, its outline and blip will glow red. When you click, the glow changes to white. 

Here we see the effect as you approach, hover over, and then click on the firework: 
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You can expand the selection by SHIFT-clicking on other 

fireworks. In the illustration, below, weõve selected two of the 

three shells in the scene: 

 

SHIFT-clicking a selected firework will remove it from the selection. 

Moving in Space 

Once youõve made your selection, you can move the selected fireworksõ launch points or target points. To 

move the launch, mouse down anywhere along the trajectory of a selected firework (this wonõt change the 

selection) and drag. All selected fireworks move together. As you drag, a òmeasuring stickó appears that 

shows you the distance from the center of the screen to the launch point of whichever firework you clicked 

on. Here, we drag our selection to the left: 

 

To bend or stretch the target points, click within the òtarget circleó at the top of the firework and drag. You 

can drag in any direction; again, the target points of all selected fireworks move in concert while the launch 

points remain where they are: 
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When you move the target point, a measuring stick (not shown in the illustration) shows you the height and 

angle of the target. By default, you can only move the targets to specific spots in the Sky Fieldñthe targets 

òsnap toó and invisible grid. If you want to smoothly adjust the targets, hold down the SHIFT key as you drag. 

Moving in Time 

Moving a firework in time is similar to moving it in space: You make your selection as before, but this time 

you click on one of the Timeline blips and drag. Moving to the left pushes the selected fireworks backwards 

in time; moving to the right is into the future. As you drag, youõll see your fireworks òperformó. For example, 

here we drag a green mine forward in time (to the right).  

 

In relation to the Playhead, the mine is getting òyoungeró, so it appears to run backwards. If you push the 

firework past the Playhead, the connection to the Sky Field disappears, and a message tells you that the object 

is no longer visible.  
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Using Launch Positions to Select Fireworks 

Launch positions arenõt just a convenient way to co-locate multiple fireworks; you can also use them as a 

selection tool. In the illustration, below, we see a group of mines that have been added to a launch position. 

Rather than selecting each firework one-by-one, you can click on the launch position marker; all of its 

fireworks are selected: 

 

As mentioned earlier, if you drag the launch position marker, all of the fireworks go with it. If you want to 

drag the fireworks out of the launch position, click on the marker (to select the fireworks), and then click and 

drag by the collected launch points: 
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6  Working With the Timeline 

This chapter looks at the tools you use to change the resolution and playback position of the Timeline, and 

the duration of your show. 

The Timeline components are illustrated below: 

 

 

 

The Playhead 

The Playhead shows you the current temporal position in your show. There are a number of ways to position 

the Playhead: 

· You can drag it. As you drag the Playhead, your fireworks launch and explode accordingly.  

· You can jump to the beginning or end of the show by pressing the HOME and END keys, respectively. 

· You can step the Playhead incrementally forward (toward the end of the show) by pressing PAGE UP (big 

step) or the RIGHT-ARROW key (small step). 

· Similarly, PAGE DOWN and LEFT-ARROW bump the Playhead back toward the beginning of the show. 

· You can start and stop the show by using the Playback Controls (which we saw in the first chapter), or by 

pressing the spacebar. 

You can also move the Playhead by dragging the zoom slider, which weõll describe later in this chapter. 

Playhead Time Zoom Buttons Time Display 

Time Zoom Slider 
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Time Zoom Buttons 

The Time Zoom Buttons let you expand and contract the Timeline. When you click the  button, you 

expand the Timeline. A smaller portion of your show is represented on the Timeline, but the Timeline blips 

òspread outó making it easier to select a specific firework. Here we see the before-and-after effect of zooming 

into the Timeline: 

 

The  button contracts time; more of your show is represented, but the blips are closer together. 

You can also zoom in and out with the Time Zoom Slider. Which method you use for zooming is a matter of 

taste. 

Time Display 

The Time Display shows you the current time location of the Playhead (on the left) and the duration of the 

entire show (on the right). Both measurements are in minutes: seconds. hundredths-of-seconds: 

 

Time Zoom Slider 

The Time Zoom Slider fulfills a number of functions. It represents the portion of the show thatõs displayed 

on the Timeline, it lets you quickly move to a different part of your show, and it lets you zoom in and out. 

The track that the zoom slider sits on represents the duration of your entire show. The zoom slider itself 

maps to the portion thatõs currently displayed in the Timeline: 

 

Playhead location Show duration 
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You can move the Time Zoom Slider by grabbing anywhere along the middle portion and dragging. This is a 

great way to quickly jump to a different part of your show. Notice that when you drag, the Playhead òsticksó 

to one edge or the otherñthe Playhead canõt scroll out of view: 

 

A particularly welcome feature of the Time Zoom Slider is that itõs resizable. Resizing the Slider is a 

convenient way to expand and contract the Timeline. As opposed to the zoom buttons, which zoom in and 

out in discrete steps, the Time Zoom Slider is continuous, letting you quickly zoom into exactly the portion of 

your show that you want to examine. 

For example, letõs say you want to see the eight-second slice of your show that starts at exactly 90 seconds in. 

First, you drag the Time Zoom Slider so the section is in view: 

 

Next, you drag the Sliderõs left thumb to the right until the 1:30 mark is at the left edge of the Timeline. (Note 

that contracting the slider zooms in; expanding it zooms out): 

 

Now drag the right thumb to the left: 

 

With just three quick mouse moves, youõve zoomed into the part of the show that youõre interested in. 
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Changing the Duration of Your Show 

By default, all shows are two minutes long. To change the duration, select the Edit > Set show duration option. 

The Set show duration window will open. Type in the new duration, in seconds, and click Set: 

 

When you increase the duration, a blank portion is added to the end of the show. If you want to add time to 

the beginning of the show, increase the showõs length, select all of the fireworks, click on a firework blip on 

the Timeline, and drag to the right. 

Be aware that the undo command (Edit > Undo or CONTROL-Z) doesnõt apply to modifications to the showõs 

duration.  
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7  Changing Backgrounds 

You set your showõs background image by selecting an image from the Background menu. If you want to add 

an image of your own, select Background > Add new background and browsing to an image file. The file must 

be in this format: 

· 5x3 ratio, width to height. (The images that are shipped with FINALE Fireworks are 1667 x1000 pixels). 

Your image will be scaled to fit the Sky Field, so it can be as small or as large as you like. 

· JPEG format. 

When you add your own background, the image is copied into the backgrounds/user  directory in the 

FINALE Fireworks installation directory, and the name of the image is added to the Background menu. Keep 

in mind that the image that you see in the program is a copy of the file that you added. If you make changes 

to the original file, you have to re-add the image and then restart the program. 

If you want to delete an image from the Background list, remove it from the backgrounds/user  directory. 

 



 

 PAGE 32 

8  Saving, Opening, and Exporting 

your Show 

To save your show, go to the File menu and select an option: 

· Save. This will upload your show to the FINALE Fireworks website where it can be viewed by other 

FINALE users. The show will be rendered as a high-resolution movie and added to the websiteõs Show 

page. It takes about an hour to complete the rendering, so you wonõt see it on the Show page immediately. 

When you select Save, youõre asked to give your show a name. 

· Save to disk. This saves your show to your local disk as an òHBSó file. The file contains everything 

FINALE needs to reconstruct your showñfirework placements, background image name, soundfile 

name, and so on. The file is text-based; if youõre intrepid, you can modify your show directly by editing 

the file. Note, however, that the HBS format isnõt currently documented, and you can easily corrupt the 

file so that FINALE wonõt be able to load it. 

· Save as to diské. This is the same as the above, but lets you save the show as a new HBS file. 

The File menuõs show-opening options are: 

· Open. When you select Open, FINALE opens a panel that lists the shows that youõve uploaded to the 

FINALE website. Note that it only lists your own showsñyou canõt open shows that were created by 

other FINALE users. 

· Open from diské lets you browse to and open a previously-saved HBS file. 

The rest of the File items are meant for real-world designers: 

· Print Inventory Report creates a printable list of the fireworks that youõre using in your show. 

· Print Loading Report creates a printable mapping of fireworks-to-launch positions, and the mapping 

between launch positions and modules/pins.  

· Print Firing Report creates a printable version of the firing script. It lists your fireworks in chronological 

order, along with their firing times and launch position information. 

· The Export éScript options create firing scripts in various industry-standard formats. 
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9  Real-World Show Design 

This chapter proposes a workflow for real-world show design and looks at the advanced aspects of FINALE 

that let you (the real-world designer) create and export the reports and scripts that youõll use in the field. 

Weõve already looked at some of the FINALE tools that can be an aid to real-world designñlaunch 

positions, in particular. In this chapter, weõll show you how to assign firing modules (including devices with 

slats) to launch positions, how to use the Firing View to view the module and pin assignments of individual 

fireworks, and how to export the reports that FINALE will generate for you.  

Real-World Workflow 

If youõre a real-world designer, your work in FINALE will probably follow this workflow. 

1 Add launch positions. Define and name a set of launch positions.  

2 Assign modules or slats. Assign one or more firing modules or slats to each of the launch positions. 

3 Add fireworks. Add fireworks to the launch positions. 

4 Assign module addresses and firing pins. Modify the fireworksõ modules and pin assignments by using the 

Firing View. 

5 Export your show. Save your show and export it as a set of reports and a firing script. 

FINALE can automate some of this work for you. Specifically, it can create and assign modules and firing 

pins automatically. Whether you take advantage of this automation depends, primarily, on your resources. If 

the number of modules that you can use isnõt an issue, and if all of the modules are the same type, then you 

can let FINALE automate all (or much) of the process for you. If your resources are limited, if your modules 

are of different types (different numbers of firing pins, specifically), of if you want to split modules across 

launch points, then you may need to create assignments by hand. 

The next few sections will concentrate on the second and fourth steps outlined above. Weõll assume that 

youõve already added launch positions to your show, a subject that weõve already discussed. (To review, you 

add a launch position by choosing the Edit > Add launch position menu item.) 
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Assigning Modules to Launch Positions 

To configure a launch positionõs attributes, right-click or double-click on the launch position marker. This will 

bring up the Edit position properties panel: 

 

The Name is provided as a convenience and is reproduced in some of the reports.  

Distance from audience sets the location of the launch position. As you increase the distance, the launch 

position is pushed away from the audience. In the Sky Field, the launch position will get smaller and òrise upó 

towards the horizon in a simulation of its real-world location. The fireworks that you add to a more distant 

launch position will appear smallerñor farther awayñthan those that are added to a closer launch position 

The most important control is Add module or slat. You can either add modules/slats to the launch position 

yourself or let FINALE add them for you. When FINALE adds a module, it creates a generic module with 

these characteristics: 

· Module type: òGeneric32ó. The type is the name of the device, used both as a convenience for the user in 

the printed reports and as information to FINALE so consideration can be made for the specific features 

or constraints of different types of modules. For example, the type òm156ó tells FINALE that youõre 

using an ATF m156. In this case, FINALE will adjust its assignment algorithm (and possibly move 

fireworks in time) to accommodate the characteristics of the m156 module. Weõll discuss the details, later; 

the point, here, is that if youõre using an ATF m156, you may want to add a module if only to assign the 

proper type. 

· Address: Starts with 1 and increases monotonically as more modules are needed.  

· First pin #: Starts with 1 and increases until the No. of pins has been reached. 

· No. of pins: 32 

· Launches/pin: 1. This attribute lets you declare the number of e-matches that are assigned to each pin, thus 

letting you economize your pin assignments. If you set the value to be greater than 1, FINALE will 

automatically assign simultaneous fireworks to the same pin until the Launches/pin setting is reached. 
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If these characteristics match your system, then you can let FINALE automate everything for youñyou donõt 

need to add a module/slat to the launch position. However, if you need to modify the settings, click the Add 

module or slat link. This will add a new entry to the table in the middle of the panel: 

 

By adding a single module, you can re-define the default settings that FINALE will use when it creates new 

modules and makes pin assignments. If youõre using different types of modules at the same launch point, add 

and define more modules as needed. If you assign more fireworks to the launch point then are 

accommodated by the modules youõve added, FINALE will automatically create modules that match the 

characteristics of the last module in the list, and will set the moduleõs address to the first available address 

value. 

Bear in mind that if you want to be able to assign module addresses and firing pins to specific fireworks, you 

must provide an address in the form, above. 

There are a lot more details to FINALEõs assignment algorithm that you should understand, but first weõll 

look at some examples that introduces the basic concepts, and also introduce the Firework View. 
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Full Automation 

In this example, weõll add two launch positions, PositionA and PositionB. Both launch positions use the 

FINALE default module (no slats, 32 pins, one launch per pin, etc). We add 36 fireworks to each position (in 

order to get over the 32 pin limit), but in three groups each, as illustrated below: 

                 

The modules and firing pins assignments are listed in the Firing View. To bring up the view, choose File > Firing 

View (or type CONTROL-F): 

 

The columns in the view should be reasonably self-explanatory (PFT means òprefire timeó). Weõve scrolled 

forward to the point in the show between the first 16 fireworks at PosA and the first of PosB. Notice that the 

module addresses jump from 1 to 3 between the two modules.  

If we scroll much farther forward, to the juncture between ò16 moreó at PosB and the òFinal 4ó at PosA, 

weõll see that address 2 was assigned to the second module in PosA: 

 

16 at PosA 

16 at PosB 16 more 
at PosA 

16 more 
at PosB 

Final 4 at 
PosA 

Final 4 at 
PosB 
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We should note, here, that of all the values in the table, only the Addr and Pin values are (potentially) 

editableñyou can modify the settings that they display in order to manually configure the assignments. 

However, this only applies to modules that have been added manually. If we click on an Addr in the current 

configuration, the only option we see is auto: 

 

Weõll look at effective manual assignment in a later example. The point, here, is that in order to edit the 

address and pin assignments, you must first add a module manually and assign an address to it in the Edit 

position properties panel. 

Also, be aware that while you can continue to add fireworks and edit launch positions while the Firing View is 

onscreen, the changes that you make arenõt immediately reflected in the Firing Viewõs table. To refresh the 

view, you must dismiss it and then bring it up again. You can dismiss the Firing View by clicking the X in the 

upper right hand corner, or by (again) typing CONTROL-F. 

Multiple Launches-per-Pin 

In this example, weõll edit the PosA launch position so that it supports 2 launches-per-pin. We double-click 

the PosA launch position to bring up the Edit position properties panel, add a module/slat, and set launches/pin 

to 2. However, in order to increase the number of launches per pin, we must assign an address. Weõll use 2. 

For the purposes of this example, weõre also going to set the number of pins to 1: 

 

When we bring up the Firing View and scroll to the top of the list, we see this: 

 



Real-World Show Design  FINALE Fireworks User Guide 

 PAGE 38 

Even though the module only has one pin, two fireworks are assigned to each module (and to the same pin), 

as we wanted. Also, notice that while the address of the first module is 2, the address of the next module 

(which is added automatically) is 1. As mentioned earlier, when FINALE assigns module addresses 

automatically, it picks the first available addressñand since address 1 wasnõt used, thatõs the address it chose. 

Using Slats 

To add a module that contains slats, double-click a launch position to bring up the Edit position properties 

panel, click the Add module or slat link, and construct the address so that it contains a number and a letter. 

(For this example weõve set the number of pins to 2 and the launches-per-pin to 1): 

 

When you use the ònumberLetteró address format, FINALE knows that youõre using slats. As you exhaust 

the pins on one slat, FINALE creates another for you, incrementing the letter portion of the address: 

 

FINALE will automatically create 12 slats, with addresses that run from a to l.  

Splitting Modules Across Launch Positions 

So far, weõve assigned all the launches from a module to a single launch position. But 

letõs say that you want a single module to control two groups of fireworks that are 

assigned to different launch positions. The first group is set of 16 fountains that are 

launched 200 feet from the audienceñthis is the main launch position. You then run 

scab wire to a second group of three large, important peonies that are launched 100 

feet farther back and to the right. In the field, the setup looks like this: 

 

To simulate this in FINALE, you create two launch positions (Main and Accent) and add the fireworks: 
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For both launch positions, bring up the Edit position properties panel and add a module with the same address 

(weõll use 1): 

 

 

By assigning the same address, you tell FINALE that the two launch positions are using the same module. 

Bring up the Firing View and scroll to the Accent fireworks: 



Real-World Show Design  FINALE Fireworks User Guide 

 PAGE 40 

 

Because the Accent fireworks appear later than the Main 

fireworks, FINALE has automatically assigned pins 17-

19 to them. But letõs say that you want them to be on 

pins 1-3. To change the assignments, click on the pin 

number and select another value: 

 

When youõre finished, the assignments look like this: 

Notice that the Accent information is presented in 

bold. This means that the assignments have been 

manually configured. FINALE wonõt alter settings 

that have been manually configured. Also notice that 

the pin assignments for Main have been bumped 

upñthatõs because pins 1, 2, and 3 are no longer 

available for automatic assignment. 

 

The Firing View 

We just saw an example of how to use the Firing View to change a pin assignment. In this section, weõll take a 

closer look at the Firing View UI and functionality. But, first, a general principle: 

· You can move your fireworks and edit launch positions while the Firing View is onscreen. However, the 

changes that you make wonõt be immediately reflected in the Firing View list. Whenever you make a change 

to a firework or launch position, you should close the Firing View and then re-open it (by typing CONTROL-F 

twice). 
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Positioning the Playhead 

As mentioned earlier, the Firing View gives you a 

chronological listing of the fireworks in your show. This 

list will, of course, become extremely long. To jump to a 

specific point in the list, move the Playhead near the 

section that youõre interested in before you type CONTROL-

F. The list will scroll to the chosen point and color the 

row of the next firework thatõs scheduled to be launched. 

For example, here weõve placed the Playhead just before 

the three peonies from our previous example: 

 

When we bring up the Firing View, it scrolls to our current position and colors the next firework: 

 

Re-assigning Addresses and Pins 

As you add fireworks to a launch position, FINALE automatically assigns module addresses and firing pins 

(as we demonstrated previously). If you want to re-assign a setting, click on the Addr or Pin value and select a 

value from the dropdown menu that appears.  

The address values that you can select from in the Firing View dropdown menus are restricted to the module 

addresses that have been specifically assigned to that launch position. For example, letõs say we have two 

launch positions, PosA and PosB. We bring up the Edit position properties panel and add two module 

addresses to each launch position, 1/ 2 for PosA and 3/ 4 for PosB: 

Playhead 

Next firework 
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Add some fireworks to both launch positions, bring up the Firing View, scroll to a PosB firework, and open 

the Address dropdown menu: 

 

The only choices you have are 3, 4, and auto. 

Conflict Detection 

The Firing View can help you find and resolve questionable pin conflicts. FINALE lets you assign any number 

of fireworks to the same pin, but warns you if the fireworks arenõt all launched at the same time. If two or 

more non-simultaneous fireworks are assigned to the same pin, the Firing View marks the conflicting fireworks 

in red.  

In the example, below, weõve created a Zippers launch position that contains a sequence of zipper effects that 

are launched one after another. Weõve edited the launch position to contain a single 32-pin module: 
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We add the zippers, bring up the Firing View, and set the pin number of the first firework to 1. The font 

changes to bold to show that the value has been manually set: 

 

Now we set the pin for a later firework to 1, as well. Because the two fireworks arenõt launched at the same 

time, FINALE detects a conflict and marks the second assignment in red: 

 

FINALE doesnõt try to correct this sort of conflict for you, it just points them out. By scanning the Firing 

View, you can easily see (and correct, if necessary) your moduleõs pin conflicts.  
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10  Creating Your Own Fireworks 

There are two ways to create a new firework in FINALE: By editing a single firework in order to create a new 

effect, by selecting a group of fireworks and saving them as a cake. This chapter looks at both methods of 

firework creation. The following chapters look at the tabs in the Firework Editor. 

Editing a Firework 

To create a new firework effect, you select an existing firework from the Inventory, add it to the scene, and 

then double-click it to bring up the Firework Editor. The Firework Editor contains a set of sliders, menus, and 

other controls that let you modify the attributes of the fireworkñthereõs no programming or file editing 

involved. 

 NOTE If youõre going to edit a firework, you shouldnõt modify its height or angle by dragging its target 

point in the Sky Field. Any hand-modifications that you make will be ignored when you save your 

new creation. 

To get started, select an 

existing firework thatõs 

similar to the one you want 

to create and add it to the 

scene by clicking its icon. 

When you add the firework, 

it will automatically become 

selected.Here, weõve 

selected the Red Ext Tail 

Comet 6ò 

Double-click anywhere 

along the fireworkõs 

outlined path or click the 

Edit button that will appear 

onscreen to open the 

Firework Editor.  
 

The Firework Editor will appear at the top of the window: 

1. Click to add 

éor click the 
Edit button 

2. Double-click 
the selected 
fireworké 



Creating Your Own Fireworks  FINALE Fireworks User Guide 

 PAGE 45 

 

As long as the Firework Editor is open, the firework will remain selected (although it might not to appear to 

be). You wonõt be able modify the firework by hand, nor can you select another firework, but the Timeline 

and Playhead are still òliveó. As youõre editing your firework, youõll be able to play your show 

 

You use the controls in the Firework Editor tabs to 

modify the firework. (Youõll need to use the slider at 

the bottom of the menu to reach all of the tabs.) The 

changes that you make are immediately applied to the 

selected firework. Here, weõve increased the size of 

the cometõs shell and added some òsparkleó. Weõve 

also moved the Playhead forward so we can get a 

better view of the changes weõre making: 

To make the changes permanent and dismiss the 

menu, click Apply. If youõre dissatisfied with what 

youõve done, click Cancel. All of the modifications 

that you made will be forgotten.  

 

Increase the size 

Add some sparkle 

Adjust the Playhead for 
better viewing 
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Saving your Firework 

After youõre finished with your modifications (and have clicked Apply), youõll return to the normal view of 

your scene. To save your creation, make sure the firework is still selected and choose 

Edit > Save selected firework from the Main Menu. This will bring up the Save Firework panel: 

 

 

 

 

 

· If youõre editing a new firework, you should change the name so it doesnõt overwrite the original object.  

· The Public checkbox lets you share your firework with other FINALE users. Leave it unchecked if you 

want to keep the firework to yourself. 

· The image below the Public checkbox is the icon that will be used to display the firework in the Inventory. 

FINALE makes a best guess at creating the icon, but you may need to use the Snapshot delay and Zoom 

sliders to adjust it.  
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When youõre ready to publish your firework, click SAVE. Your firework will be added to your local Inventory 

and uploaded to the FINALE Website. If the save is successful, youõll see this message: 

 

The panel will disappear after a few seconds, or you can dismiss it by clicking the close button. 

If you tried to save a firework without changing its name, youõll see this: 

 

This isnõt necessarily an error. Youõll see this message if youõre making iterative changes to your own 

fireworks; in this case, click UPDATE. Youõre not allowed to update the standard fireworks or those created by 

other users. 

To find your firework in the Inventory, select My private fireworks from the first pulldown menu (make sure 

youõre in the correct category, and have selected the proper caliber): 

 

Creating a Cake 

A cake combines any number of other fireworks into a single effect. The individual fireworks that you add to 

a cake can include the fireworks that youõve edited, and can come from any of the firework categoriesñyou 

can even create a cake by combining other cakes. 

An important difference between editing a firework and creating a cake is that you are allowed to hand-modify 

the heights and angles of the individual fireworks that comprise the cake. The modifications that youõve made 

will become part of the cakeõs definition. 
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To get started, add some number of 

fireworks to the scene. Here, weõve added a 

mine, two comets, and two fountains. 

Weõve also adjust the angles of the 

fountains and comets so theyõre 

symmetrically distributed around the mine. 

 

 

Next, shift-click to select all of the 

fireworks, and then choose Edit > Save 

selected fireworks as cake. Youõll see the 

same Save Firework panel that we described 

earlier. Give your cake a name, make it 

public (or not), adjust the snapshot, and 

click SAVE. 

The original fireworks that you used to 

create the cake donõt become a cake, 

themselvesñthey remain as separate 

fireworks.  

To find the cake you created and add an 

instance of it to the show, go to the Cake 

category of your inventory and look in the 

My private fireworks section.   

As mentioned above, a cake is treated as a single effect. When you modify a cakeõs launch position or its 

placement on the timeline, all of the fireworks that make up the cake move together. However, you canõt 

change a cakeõs height or its angle. 

You can òbreak apartó a cake, and thus turn it back into individual fireworks, by selecting the cake and then 

choosing the Edit > Break apart cake menu item. 
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Managing your Personal Inventory 

If you want to delete a firework that youõve created, go to Edit > Manage personal inventory: 

 

This will bring up the Personal Inventory panel: 

 

The panel lists all the fireworks that youõve saved (both individual fireworks and cakes). To delete a firework, 

click the delete button at the far right. When youõve finished, click Done.
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11  Common Tabs 

This chapter lists the tabs that are common (or nearly so) to all fireworks. 

Firework 

 

The Firework tab sets some basic attributes of your firework.  

Name Attribute 

Name Text 

The name of the firework as itõs displayed to the user. The name mustnõt contain accented characters or any 

other formatting. The text field only accepts simple ASCII characters; non-ASCII characters are removed 

from the text that you supply. 

Category Menu 

The category in which the firework will be listed in the FINALE application. You should rarely need to 

change a fireworkõs category. The choice you make wonõt affect the fireworkõs appearance; for example, if 

youõre editing a mine, setting the Category to Fountain wonõt turn your design into a fountain. The firework 

isnõt placed in the selected category until you publish it through the Edit > Save selected firework. If you 

change the Category setting for an existing firework (and Save), the firework is removed from its current 

category and moved to the new one. 

Caliber Menu 

NOTE Fountains donõt have a Caliber control. Instead, they have a Duration. This is explained in the 

Fountain chapter. 

The caliber of the launching device. The menu provides options that let you choose from among a dozen 

industry-standard sizes, from 1 inch to 10 inches. 

The caliber affects almost all aspects of a fireworkñitõs size, velocity, and duration, and so on. It also 

indirectly influences the velocity of the stars that a shell produces.  
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Name Attribute 

Prefire Slider (seconds) 

Prefire is the delay between the time a firework is launched and the time that it òreveals itselfó. What this 

means depends on the type of firework: 

Non-shells (mines, comets, fountains, and candles) reveal themselves almost immediately, so their prefire 

durations are extremely short (0.3 seconds by default). For these fireworks, the Prefire setting places the 

òblipó on the Timeline, but it doesnõt affect the firework itself. For example, if you increase the Prefire value, 

the blip will move to the right, but the firework itself wonõt look any different. You should rarely need to 

change the Prefire value for a non-shell. 

For a shell, the Prefire setting also sets the Timeline blip; in addition, it sets the amount of time between the 

shellõs launch and its burst. The greater the Prefire value, the farther the shell will travel before it bursts. If 

you set the value to 0.0 (for a shell), FINALE computes the prefire duration for you based on the shellõs 

caliber. 
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Field notes 

 

The Field notes tab lets you add a description, explanation, instruction or any other arbitrary text to your 

firework. Provided primarily for the pro, the notes that you supply will appear in the reports that you 

generate. 

Name Attribute 

Notes Text 

Arbitrary text thatõs added to the firework. The text can be of any length, but may only contain normal 

ASCII charactersñit canõt contain accents or other special characters. Non-ASCII characters are removed 

from the text. 



 

 PAGE 53 

12  Peony 

A peony is a shell that bursts into a spherical set of stars and pistils. The stars can have two layers of 

pyrotechnic material. After a star burns through its first layer, it transitions into a second effect. 

 

 

 

 

  



Peony  FINALE Fireworks User Guide 

 PAGE 54 

Launch 

 

The Launch tab defines the attributes of the shellõs launch.  

Name Attribute 

Cone angle Slider (degrees) 

A shellõs cone angle is the angle across which successive launches are randomly distributed. The center of the 

angle is straight up. As you increase the cone angle value, the cone widens symmetrically around the center. 

NOTE The adjustments that you make to the cone angle wonõt affect the firework that youõre currently 

editing. The setting is applied after youõve saved your firework and added a new instance to the 

scene. 

Cone height Slider (scaler; 1.0 = natural height) 

By default, the height (or distance) of a shellõs trajectory is determined by the velocity with which itõs 

launched, and velocity is directly related to the mortarõs caliber (and some other physical properties).  

The Cone height slider lets you adjust the shellõs velocity (and so its height). If you set the slider to 1.0, you 

get the velocity/height thatõs determined by the caliber. Values greater than 1.0 produce greater heights, as 

much as twice as high as the natural caliber height. Values less than 1.0 reduce the height. If you set the 

value to 0.0, the firework wonõt lift off at all. 

Keep in mind that youõre increasing and decreasing the shellõs velocity. The duration of its trajectory will be 

the same regardless of this sliderõs value. Thus, you can adjust the cone height without invalidating the 

shellõs prefire setting. 

Randomness Slider (Fraction; only affects new fireworks) 

The velocity with which a shell is launched is set naturally by its caliber. The Randomness slider lets you add 

some randomness to the velocity. As you increase the sliderõs value, the range of velocities widens, but 

theyõre always less than the natural velocity thatõs set by the shellõs caliber. For example, letõs say youõre 

creating firework that launches a shell with an initial velocity of 400 ft/sec. If you set the Randomness to 

0.00, the shells will always emerge with (nearly) the same initial velocity (400 ft/sec). A value of 0.5 means 

shell could emerge with an initial velocity thatõs anywhere between 200 and 400 ft/sec.  

  



Peony  FINALE Fireworks User Guide 

 PAGE 55 

Shell tail 

 

A shellõs tail is the trail of glowing particles that it leaves behind after itõs launched and that lasts until it bursts. 

You make the tail visible by setting the Tail effect, below, to something other than No tail. You can then set the 

tailõs color through the other control.  

Name Attribute 

Tail effect Menu 

Lets you choose the type of tail you want the shell to display: 

No tail. Use this effect to turn off the tail. 

Thin. The particles are equally-spaced along the trajectory, and are of the same brightness and duration 

(although with some randomness thrown in). The particles stay fairly close to the path of the trajectory. 

Thick. This is the same as Thin but there are more particles, and they trace a wider path. 

Color Color picker 

Sets the tailõs color.  
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Shell burst 

 

The Shell burst controls set some basic attributes of the stars that emerge when the shell bursts (or òbreaksó).  

Name Attribute 

No. of Stars Slider (Count) 

Sets the number of stars that each shell contains. When the shell bursts, the stars are thrown in random 

directions away from the shell, creating a peony effect. If you set No. of stars to 0, the shell wonõt throw any 

stars. The starsõ attributes (color, weight, sound, and so on) are set through the various Star tabs. 

Burst force Slider (Scaler; 1.0 = natural size) 

Sets the power with which the stars break from the shell. 1.0 is the shellõs natural burst power, based on the 

caliber of the shell and other physical properties. Other values are applied as scalers on the natural power: 

0.5 means the stars are thrown half has hard; 2.0 means theyõre thrown twice as hard. A setting of 0.0 means 

that thereõs virtually no powerñthe stars fall out of the break with very little outward momentum.  

Note that the Burst force setting affects the sound volume of the report. If you want to create a weak shell 

with a loud report, you have to increase the Report > Loudness setting. 

No. of Pistils Slider (Count) 

Pistil burst force Slider (Scaler; 1.0 = natural size) 

These two controls are similar to the first two, but are applied to the shellõs pistils. A pistil creates a trail 

effect thatõs similar to a starõs tail; however, pistils are independent of stars. When the shell bursts, the pistils 

are thrown in random directions away from the shell, creating the òspokesó in a peony effect. The pistilõs 

other attributes are set in the various Pistil tabs. 
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Shell burst sound 

 

The Shell burst sound controls let you select and modify the sound thatõs played when the fireworkõs shell 

finishes its trajectory (the sound is played even if the shell doesnõt actually burst).  

Name Attribute 

Sound Menu 

The Sound menu gives you a choice of sounds that are played when the shell bursts. The names of the 

sounds that you can choose from are self-descriptive: Whoosh, Pop, Thud shriek, and so on. 

Volume Slider (Fraction) 

Sets the amplitude of the sound as a percentage of its unattenuated amplitude. A volume of 1.0 is 

completely unattenuated; a volume of 0.0 is silent. The amplitude isnõt affected by the fireworkõs caliber or 

the Shell burst > Burst force setting; for example, if you increase a fireworkõs caliber, the shellõs burst sound 

doesnõt get louder. 

Pitch shift Slider (-1.0 = one octave lower; 1.0 = one octave higher) 

Shifts the pitch of the sound by as much as an octave lower (-1.0) to an octave higher (1.0). Pitch shifting is 

effected by changing the playback speed of the soundfile. Shifting the sound lower will increase its duration; 

shifting it higher will increase the duration. 

Random pitch shift Slider (-1.0 = one octave lower; 1.0 = one octave higher) 

Adds a random amount of pitch shift to the sound of each shell burst. You can declare a random pitch shift 

from an octave lower to an octave higher than the pitch defined by the Pitch shift attribute. For example, if 

you set Pitch shift to -0.5 (half an octave lower than the ònaturaló pitch of the sound) and set Random pitch 

shift to 0.3, the pitch shift for a specific burst will be somewhere between -0.2 (a fifth of an octave below the 

natural pitch) and -0.5 (a half an octave lower than natural). 
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Star 

 

A star is created when particles of pyrotechnic composition material are ignited and emitted by a bursting 

shell. The Star tab defines the basic attributes of a star, such as its duration and whether itõs accompanied by a 

tip. A starõs forceñbut not its durationñis affected by the Shell burst > Burst force setting. 

Name Attribute 

Longevity Slider (Scaler; 1.0 = natural longevity) 

Sets the amount of time between the starõs emergence from the bursting shell and the time that its 

pyrotechnic material is exhausted. The slider value isnõt an amount of time in seconds: Itõs a scaler on the 

starõs natural duration, which is determined by its caliber, speed, and other factors. This natural duration is 

represented by a value of 1.0. If you set the slider to 0.5, for example, the duration between the burst and 

the time that the star is exhausted will be half as long as the natural duration. If you want to extend the 

starsõ trajectories, increase the longevity value. 

Abridgment Slider (Fraction) 

Abridgment adds a bit of randomness to the starõs longevity. With a setting of 0.0, thereõs no randomnessñ

all stars that burst from a shell last (approximately) the same amount of time (as set through the Longevity 

slider). As you increase the Abridgment value, you reduce the duration range. For example, a setting of 0.5 

means that a star may die out any time after half of its longevity has expired.  

The Abrigment setting never increases a starõs duration so that it lasts longer than the Longevity settingñit can 

only decrease it. 

Tip effect Menu 

Lets you choose the type of tip you want the star to display: 

No tip. Turns off the tip. 

Constant. All star tips appear together, last for the same amount of time, and burn with the same intensity. 

Strobe. Some randomness is added to the initial appearances, durations, and intensities of the tips, creating a 

strobe effect. 
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Star body 

 

The Star body controls let you fine-tune a starõs mass so that itõs more or less susceptible to air friction, 

gravity, and wind. These attributes only affect the starsõ trajectories; they donõt modify the size or appearance 

of the stars. 

Name Attribute 

Weight Slider (Scaler; 1.0 = natural weight) 

Sets the starõs weight. A value of 1.0 is the starõs ònaturaló weight. If you increase the value, the star 

becomes heavier and is pulled back to Earth more quickly. Smaller values make the star lighter and so the 

straight-outward portion of its trajectory is less affected by gravity. 

Momentum Slider (Scaler; 1.0 = natural momentum loss) 

As a star consumes its pyrotechnic material, it loses mass and momentum, and thus slows down and 

becomes increasingly more susceptible to the effects of the wind and air friction. This attribute lets you set 

the scale of the starõs ultimate momentum (the point at which it has exhausted its material) compared to its 

burst momentum. A value of 1.0 produces a ònaturaló momentum loss. If you increase the value, the star 

maintains more of its momentum over the course of its trajectory. If you decrease the value, the star loses 

momentum more quickly. 

Wind resistance Slider (Scaler; 1.0 = natural wind resistance) 

Sets the starõs susceptibility to the wind and air friction. A value of 1.0 produces a slight, natural resistance. 

Decreasing the sliderõs value makes the star less affected by the wind, causing its trajectory to straighten and 

elongate. Increasing the value increases the effect of the wind and air friction on the star, shortening its 

trajectory and bending it in the direction of the wind. 
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Star tip 

 

The tip of a star is its leading edge as it burst from a shell. The tip can begin òglowingó as soon as the star 

emerges and can continue through the starõs duration. You make the tip visible by setting the Star > Tip effect 

to something other than No tip. You then set the tipõs other attributes through the controls in this tab.  

Name Attribute 

Color Color picker 

Sets the tipõs color.  

Second color Color picker 

If you set the starõs second color, half of the stars will be painted with the main color (the Color setting) and 

the other half will be painted with the second color. The colors are randomly distributed amongst the stars. 

Not all palms have a Second color control. 

Size Slider (Scaler) 

Sets the magnitude of the tipõs glow. Unlike a shell tip, a star tip doesnõt have a ònaturaló size thatõs based 

on the Fireworks > Caliber setting. As you select larger or smaller caliber settings, youõ may want to increase 

or decrease the value of this attribute. 
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Star transition 

 

After a star has exhausted a layer of its pyrotechnic material, it can transition into a second layer of material 

that can create an effect thatõs different from the first. This second effect displays tips but not tails.  

Name Attribute 

Tip effect Menu 

Lets you choose the type of tip you want the transition effect to display: 

No tip. Turns off the tip. 

Constant. All tips appear together, last for the same amount of time, and burn with the same intensity. 

Strobe. Some randomness is added to the initial appearances, durations, and intensities of the tips, creating a 

strobe effect. 

Delay Slider (Seconds) 

Sets the amount of time, in seconds, that the transition effect appears after the original effect has burned 

through its pyrotechnic material. 

Longevity Slider (Scaler; 1.0 = natural longevity) 

Sets the amount of time between the transition effectõs initial appearance and the time that its pyrotechnic 

material is exhausted. The slider value isnõt an amount of time in seconds: Itõs a scaler on the effectõs natural 

duration, which is determined by its caliber, speed, and other factors. This natural duration is represented by 

a value of 1.0. If you set the slider to 0.5, for example, the duration will be half as long as the natural 

duration. If you want to extend the trajectories, increase the longevity value. 
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Transition tip 

 

The Transition tip tab sets the color and size of the tips that are displayed by the transition effect. 

Name Attribute 

Color Color picker 

Sets the tipõs color.  

Size Slider (Scaler) 

Sets the magnitude of the tipõs glow. The tip doesnõt have a ònaturaló size thatõs based on the Fireworks > 

Caliber setting. As you select larger or smaller caliber settings, you may want to increase or decrease the 

value of this attribute. 
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Pistil 

 

A pistil is a star thatõs notable more for its tail than its tip. When a shell bursts, its pistils are thrown in random 

directions away from the shell, creating the òspokesó in a peony effect. The pistilõs other attributes are set in 

the various Pistil tabs. 

You set the number of pistils in the Shell burst tab. 

Name Attribute 

Longevity Slider (Scaler; 1.0 = natural longevity) 

Sets the amount of time between the pistilõs emergence from the bursting shell and the time that its 

pyrotechnic material is exhausted. The slider value isnõt an amount of time in seconds: Itõs a scaler on the 

pistilõs natural duration, which is determined by the fireworkõs caliber, speed, and other factors. This natural 

duration is represented by a value of 1.0. If you set the slider to 0.5, for example, the duration between the 

burst and the time that the pistil is exhausted will be half as long as the natural duration. If you want to 

extend the pistilõ trajectories, increase the longevity value. 

Abridgment Slider (Fraction) 

Abridgment adds a bit of randomness to the pistilõs longevity. With a setting of 0.0, thereõs no randomnessñ

all pistils that burst from a shell last (approximately) the same amount of time (as set through the Longevity 

slider). As you increase the Abridgment value, you reduce the duration range. For example, a setting of 0.5 

means that a pistil may die out any time after half of its longevity has expired.  

The Abrigment setting never increases a pistilõs duration so that it lasts longer than the Longevity settingñit 

can only decrease it. 
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Pistil body 

 

The Pistil body controls let you fine-tune a pistilõs mass so that itõs more or less susceptible to air friction, 

gravity, and wind. These attributes only affect the pistilõ trajectories; they donõt modify the size or appearance 

of the stars.   

Name Attribute 

Weight Slider (Scaler; 1.0 = natural weight) 

Sets the weight of a single pistil. A value of 1.0 is the pistilõs ònaturaló weight. If you increase the value, the 

pistil becomes heavier and is pulled back to Earth more quickly (it appears to droop). Smaller values make 

the pistil lighter and so the straight-outward portion of its trajectory is less affected by gravity. 

The Pistil tail tab also has a Weight attribute. The two Weight controls affect different aspects of the pistilõs 

trajectory: This attribute affects the weight of the pistilõs star, bending its trajectory. The Weight controls in 

the Pistil tail tab set the weight of the particles along the entire tail. When you increase the weight of this 

attribute, you cause the stars to arc and then droop; when you increase the weight of the pistilõs tail, the 

effect is that of òpulling downó the entire tail from the pistilõs initial burst point. 

Momentum Slider (Scaler; 1.0 = natural momentum loss) 

As a pistil consumes its pyrotechnic material, it loses mass and momentum, and thus slows down and 

becomes increasingly more susceptible to the effects of the wind and air friction. This attribute lets you set 

the scale of the pistilõs ultimate momentum (the point at which it has exhausted its material) compared to its 

burst momentum. A value of 1.0 produces a ònaturaló momentum loss. If you increase the value, the pistil 

maintains more of its momentum over the course of its trajectory. If you decrease the value, the pistil loses 

momentum more quickly. 

Wind resistance Slider (Scaler; 1.0 = natural wind resistance) 

Sets the pistilõs susceptibility to the wind and air friction. A value of 1.0 produces a slight, natural resistance. 

Decreasing the sliderõs value makes the pistil less affected by the wind, causing its trajectory to straighten 

and elongate. Increasing the value increases the effect of the wind and air friction on the pistil, shortening 

its trajectory and bending it in the direction of the wind. 
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Pistil tail 

 

This tab sets the attributes of the pistilõs tail. Additional pistil tail attributes are set through the Pistil glitter tab. 

Name Attribute 

Color Color picker 

Sets the color of the pistilõs tail. (NOTE: The Bright: slider in the Color picker is ignored. The tailõs brightness 

is set by the Brightness control.) 

Brightness Slider (Scaler) 

Controls the brightness of the tailõs color. Increasing the value of the slider causes the tail to become more 

intense. 

Weight Slider (Scaler; 1.0 = natural weight) 

Sets the weight the individual particles in the pistilõs tail. A value of 1.0 is a particleõs ònaturaló weight (which 

is very close to weightless). If you increase the value, the particles become heavier and are pulled back to 

Earth, causing the entire tail to appear to be òpulled downó from its launch point. Smaller values make the 

particles lighter and less affected by gravity. 

The Pistil tab also has a Weight attribute. A discussion of the difference between the two weights is provided 

in the Weight description in the Pistil tab. 

Length Slider (Scaler; 1.0 = natural length) 

Sets the longevity of the particles in the pistilõs tail (in other words, the amount of time before theyõre 

extinguished). By increasing or decreasing this value, you can cause more or less of the tail to be visible at a 

given time. 
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Pistil glitter 

 

A pistilõs tail can contain glitter. These are particles that have more of a shimmer when compared to the tailõs 

normal particles. 

Name Attribute 

Brightness Slider (Scaler) 

Controls the brightness of the tailõs glitter particles. Increasing the value of the slider causes the glitter to 

become more intense. 

Density Slider (Fraction; 0.0 = no glitter) 

Adjusts the proportion of glitter compared to the tailõs normal particles. If you set the value to 0.0, you get 

no glitter; if you set it to 1.0, all of the particles will glitter. 
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13  Chrysanthemum, Kamuro, 

Diadem, Brocade, Willow, and 

Dahlia 

The fireworks in this chapter are composed much like peonies: Theyõre shells that burst into stars (which can 

transition into a second effect) and pistils.  
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Launch 

 

The Launch tab defines the attributes of the shellõs launch. . 

Name Attribute 

Cone angle Slider (degrees) 

A shellõs cone angle is the angle across which successive launches are randomly distributed. The center of the 

angle is straight up. As you increase the cone angle value, the cone widens symmetrically around the center. 

NOTE The adjustments that you make to the cone angle wonõt affect on firework that youõre currently 

editing. The setting is applied after youõve saved your firework and added a new instance to the 

scene. 

Cone height Slider (scaler; 1.0 = natural height) 

By default, the height (or distance) of a shellõs trajectory is determined by the velocity with which itõs 

launched, and velocity is directly related to the mortarõs caliber (and some other physical properties).  

The Cone height slider lets you adjust the shellõs velocity (and so its height). If you set the slider to 1.0, you 

get the velocity/height thatõs determined by the caliber. Values greater than 1.0 produce greater heights, as 

much as twice as high as the natural caliber height. Values less than 1.0 reduce the height. If you set the 

value to 0.0, the firework wonõt lift off at all. 

Keep in mind that youõre increasing and decreasing the shellõs velocity. The duration of its trajectory will be 

the same regardless of this sliderõs value. Thus, you can adjust the cone height without òinvalidatingó the 

shellõs prefire setting. 

Randomness Slider (Fraction; 0.0 = autocompute) 

The velocity with which a shell is launched is set naturally by its caliber. The Randomness slider lets you add 

some randomness to the velocity. As you increase the sliderõs value, the range of velocities widens, but 

theyõre always less than the natural velocity thatõs set by the shellõs caliber. For example, letõs say youõre 

creating firework that launches a shell with an initial velocity of 400 ft/sec. If you set the Randomness to 

0.01, the shells will always emerge with (nearly) the same initial velocity (400 ft/sec). If you set the value to 

0.5, a shell could emerge with an initial velocity thatõs somewhere between 200 and 400 ft/sec.  

A value of 0.0 tells FINALE to select a physically reasonableñbut fairly smallñrange of velocities. 
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Shell tail 

 

A shellõs tail is the trail of glowing particles that it leaves behind after itõs launched and that lasts until it bursts. 

You make the tail visible by setting the Tail effect, below, to something other than No tail. You can then set the 

tailõs color through the other control.  

Name Attribute 

Tail effect Menu 

Lets you choose the type of tail you want the shell to display: 

No tail. Use this effect to turn off the tail. 

Thin. The particles are equally-spaced along the trajectory, and are of the same brightness and duration 

(although with some randomness thrown in). The particles stay fairly close to the path of the trajectory. 

Thick. This is the same as Thin but there are more particles, and they trace a wider path. 

Color Color picker 

Sets the tailõs color.  
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Shell burst 

 

The Shell burst controls set some basic attributes of the stars that emerge when the shell bursts (or òbreaksó).  

Name Attribute 

No. of Stars Slider (Count) 

Sets the number of stars that each shell contains. When the shell bursts, the stars are thrown in random 

directions away from the shell, creating a peony effect. If you set No. of stars to 0, the shell wonõt throw any 

stars. The starsõ attributes (color, weight, sound, and so on) are set through the various Star tabs. 

Burst force Slider (Scaler; 1.0 = natural size) 

Sets the power with which the stars break from the shell. 1.0 is the shellõs natural burst power, based on the 

caliber of the shell and other physical properties. Other values are applied as scalers on this natural power: 

0.5 means the stars are thrown half has hard; 2.0 means theyõre thrown twice as hard. A setting of 0.0 means 

that thereõs virtually no powerñthe stars fall out of the break with very little outward momentum.  

Note that the Burst force setting affects the sound volume of the report. If you want to create a weak shell 

with a loud report, you have to increase the Report > Loudness setting. 

No. of Pistils Slider (Count) 

Pistil burst force Slider (Scaler; 1.0 = natural size) 

These two controls are similar to the first two, but are applied to the shellõs pistils. A pistil creates an effect 

thatõs similar to a starõs tail; however, pistils are independent of stars. When the shell bursts, the pistils are 

thrown in random directions away from the shell, creating the òspokesó in a peony effect. The pistilõs other 

attributes are set in the various Pistil tabs. 

  


































































































































































































