## Contents

1. **Introduction** ......................................................................................................................... 4
   - Logging In ............................................................................................................................. 4

2. **User Interface Layout** ......................................................................................................... 6
   - Other Views .......................................................................................................................... 8

3. **Working with Fireworks** ..................................................................................................... 10
   - The Inventory ....................................................................................................................... 10
     - Firework Categories ......................................................................................................... 10
     - Expanding your Inventory ............................................................................................... 11
   - Adding a Firework to Your Show ......................................................................................... 12
     - Click to Add ...................................................................................................................... 12
     - Drag and Drop .................................................................................................................. 13
       - Note for the Real-World Designer: Obeying the Caliber ............................................... 14
   - Deleting Fireworks .............................................................................................................. 14

4. **Launch Positions: The Basics** ............................................................................................. 15
   - Creating a Launch Position ................................................................................................. 15
   - Deleting Fireworks and Launch Positions ........................................................................ 16

5. **Adding Fireworks in Time** .................................................................................................. 17
   - Adding Fireworks as the Playhead Is Moving .................................................................... 17
   - Modifying a Firework ......................................................................................................... 18
     - Making a Selection .......................................................................................................... 18
     - Moving in Space .............................................................................................................. 19
     - Moving in Time ............................................................................................................... 20
   - Using Launch Positions to Select Fireworks ..................................................................... 21
# Introduction

## 6 Working With the Timeline

- The Playhead
- Time Zoom Buttons
- Time Display
- Time Zoom Slider
- Changing the Duration of Your Show

## 7 Changing Backgrounds

## 8 Saving, Opening, and Exporting your Show

## 9 Real-World Show Design

- Real-World Workflow
- Assigning Modules to Launch Positions
- Full Automation
- Multiple Launches-per-Pin
- Using Slats
- Splitting Modules Across Launch Positions
- The Firing View
  - Positioning the Playhead
  - Re-assigning Addresses and Pins
- Conflict Detection

## 10 Creating Your Own Fireworks

- Editing a Firework
- Creating a Cake
Introduction

Welcome to FINALE Fireworks, a visual simulation and choreography program that lets you create and control a complete fireworks display. The program can be used by fireworks professionals and amateurs who are designing real-world fireworks shows, as well as by enthusiasts and artists working in the virtual world. FINALE Fireworks provides a simple and intuitive interface that lets you build a performance by dragging-and-dropping individual shells onto a “Sky Field” canvas. You can add and synchronize music, insert a background that depicts an actual shoot site, capture your creation as a “firing script” (indispensable for the real-world designer), and even record a video that you can share with your friends.

The graphical engine that creates the fireworks simulation in FINALE fireworks doesn’t use pre-rendered images or simple “wireframe” outlines. All of the shots you’ll see when you play your show are created in real-time, based on the physical properties of the mortars, shells, and other components that professionals use when designing an event—with just enough natural randomness to make each performance a unique experience.

This Users Guide tells you everything you need to know to create a fireworks show with FINALE Fireworks.

Logging In

The first thing you have to do, of course, is download the FINALE Fireworks software. If you’re reading this, you’re probably already running the program, but just in case, you can find the latest version of the program at the FINALE Fireworks website:

http://www.finalefireworks.com/

The Website will step you through the process of creating an account and will download the latest version of the program. If you’ve accepted the default installation location, you’ll be able to launch FINALE Fireworks by double-clicking...

C:\Program Files\FINALE Fireworks\FINALE Fireworks.bat
After launching the program, you'll see the login panel:

The only wrinkle, here, is that you must be connected to the Internet so the program can download the latest fireworks catalog. If you see the “Network error: communication failure” message when you log in…

...check your Internet connection.
2 User Interface Layout

In this chapter we'll look at the general layout of the FINALE Fireworks user interface. Except for a couple simple editing windows, everything you need to create a fireworks show is presented in a single workspace. The illustration, below, points out the principal components of the workspace:

In subsequent chapters, we’ll take a closer look at most of these components. Briefly, they are:

- **Main Menu.** The options in the Main Menu let you open and save shows, switch backgrounds, create “Launch Positions”, add music to your show, and so on. For real-world designers, the **File** submenu lets you write your show as a firing report in a number of standard formats.
• **Inventory.** The Inventory section lists the fireworks that you can drop into your show. Every time you launch program, the application connects to the FINALE Fireworks website and downloads fireworks into your Inventory, so your fireworks list will always be up-to-date.

• **Sky Field.** This is where your show is displayed. You can drag-and-drop fireworks into the Sky Field, move their launch and “target” positions (the target is the firework’s highest point), delete individual or groups of fireworks, and so on.

• **Wind Slider.** FINALE can add a wind effect to your show. You increase and decrease the wind (and change its direction) by moving the Wind Slider up and down. As you move the slider, the speed and direction of the wind is displayed above the Wind icon. To remove all wind, move the slider to the vertical center of the window.

• **Zoom Slider.** When you launch FINALE Fireworks, the Sky Field is set to simulate an area that’s about 900 feet high and 2000 feet wide. If you resize the window, the resolution changes—your fireworks will appear to be closer or farther away—but the dimensions of the simulated area don’t change. To zoom in and out of the Sky Field, move the Zoom Slider up and down. The simulated height is displayed above the icon as you move the slider.

• **Timeline.** The Timeline shows the temporal positions of your fireworks. In the illustration, we see three fireworks, represented by the white “blips” along the Timeline. Exactly which part of the firework a blip represents depends on the type of firework: For shells, it’s the burst event; for fountains, comets, and mines, it’s the launch. If you look closely, you can see a wavy black section superimposed on the Timeline. This is the waveform of the music that you’ve added to your show, making it easy to synchronize your show to your soundtrack.

• The **Playhead** represents the current moment that’s being displayed in the Sky Field, and moves left-to-right as you play your show. You can drag the Playhead to quickly “scrub” through your show.

• **Playback Controls.** The Playback Controls that are displayed onscreen let you start and pause your show, and rewind to the beginning. A number of other controls (incremental fast forward and rewind, seek to end, and so on) are provided in the **File > Timeline** submenu. All of the controls, onscreen or not, are bound to keyboard keys making it easy to control your show. Most notably, the spacebar toggles between **Play** and **Pause**, and arrow-left/arrow-right moves a paused show forwards and backwards by a single frame.
Other Views

In addition to the default workspace, FINALE presents two other important views: The **Firework Editor** and the **Firing View**.

- The **Firework Editor** presents a set of sliders, menus, and other controls that let you modify the attributes of a firework. To display the **Firework Editor**, you double-click on a firework that you’ve added to your show. The editor is presented as a series of tabs across the top of the main window:

![Firework Editor](image)

The **Firework Editor** is described in detail in a separate *Creating Your Own Fireworks* book. A brief outline of firework editing is presented in the *Creating Your Own Fireworks* chapter in this book.
The **Firing View** is a list of the fireworks that you’ve added to your show, in chronological order. To bring up the **Firing View**, choose **File > Firing View** or type **CONTROL-F**:

<table>
<thead>
<tr>
<th>Burst</th>
<th>Std</th>
<th>Name</th>
<th>Col</th>
<th>Ave</th>
<th>Position</th>
<th>Mod</th>
<th>Slot</th>
<th>Addr</th>
<th>Pin</th>
</tr>
</thead>
<tbody>
<tr>
<td>00:07.75</td>
<td>0.85</td>
<td>Grasshopper 3rd</td>
<td>3’’</td>
<td>6’’</td>
<td>PosA</td>
<td>Cylinder</td>
<td>0</td>
<td>01</td>
<td>01</td>
</tr>
<tr>
<td>00:07.75</td>
<td>0.30</td>
<td>Grass Mine 30 retreated 6’’</td>
<td>6’’</td>
<td>6’’</td>
<td>PosB</td>
<td>Cylinder</td>
<td>0</td>
<td>01</td>
<td>07</td>
</tr>
<tr>
<td>00:08.00</td>
<td>0.30</td>
<td>ISHOT 4R Bl 4R Witch Mine Candle 6’’</td>
<td>6’’</td>
<td>6’’</td>
<td>Position</td>
<td>ISHOT_300_4R</td>
<td>0</td>
<td>01</td>
<td>02</td>
</tr>
<tr>
<td>00:08.00</td>
<td>0.30</td>
<td>ISHOT 4R Red Witch Mine Candle 6’’</td>
<td>6’’</td>
<td>6’’</td>
<td>Position</td>
<td>ISHOT_300_4R</td>
<td>0</td>
<td>01</td>
<td>01</td>
</tr>
<tr>
<td>00:08.00</td>
<td>0.30</td>
<td>ISHOT 6R Blue Witch Mine Candle 6’’</td>
<td>6’’</td>
<td>6’’</td>
<td>Position</td>
<td>ISHOT_300_6R</td>
<td>0</td>
<td>01</td>
<td>01</td>
</tr>
</tbody>
</table>

The **Firing View** is described in the **Real-World Show Design** chapter in this book.
Working with Fireworks

In this chapter, we’ll look at how you choose a firework and add it to your show. We’ll also look at how you select, place, modify, and delete fireworks.

The Inventory

The Inventory section of the UI contains all the fireworks that you can add to your show. When you log in, the program forms a connection to the FINALE Fireworks website and downloads the latest set of fireworks, including the fireworks that you’ve designed and those that you’ve selected from other FINALE users.

Firework Categories

There are a number of ways you can search for a firework. First, you can search by category. There are six firework categories, represented by the six tabs that run across the top of the Inventory:

- The subcategories provide a further categorization of the fireworks type. Currently, only the Shells and Candle types have subcategories.
You can choose from three collection options: **Standard fireworks** is the set that’s provided by FINALE; **My fireworks** are the effects that you’ve created or have selected from other users; **All collections** is a combination of the two.

The color dropdown menu applies to all fireworks types. It lets you search for a firework that paints a particular color, whether in its tail or its burst. Many fireworks have more than one color.

The caliber dropdown also applies to all types. The larger the caliber, the bigger (and higher) the firework.

**Expanding your Inventory**

You can add fireworks to your inventory through the **Edit > Add new fireworks** option. This will bring up the **Add Fireworks** window:

![Add Fireworks window](image)

To add a firework, click the corresponding **copy** link. The firework will be added to your **My fireworks** collection.

To delete a firework from your **My fireworks** collection, go to **Edit > Manage** my fireworks. A panel similar to the one above will appear that lets you remove individual effects.
Adding a Firework to Your Show

After you’ve found the firework that you want, it’s time to add it to the show. There are two ways to add a firework:

- By clicking on its icon in the Inventory.
- By dragging and dropping the icon into the Sky Field.

The difference between these two methods is the way in which the firework is placed in the scene, as described in the following sections.

**Click to Add**

When you click an icon, the firework is dropped into the scene with its launch point set just above the launch caret that sits on the imaginary launch line, and its height (or target point) is defined by its caliber. Here, we’ve clicked on the 5” Red Ext Comet:

You can drag the launch point after you’ve dropped it, but only horizontally. You can’t drag a launch point up into the Sky Field—it always lies on the launch line at the bottom of the Sky Field. When you drag a firework’s launch point, the launch caret goes with it. The next firework you click-to-add will drop into this new location. (Note that you can’t move the launch caret by hand.)
Working with Fireworks

Notice that the firework’s trajectory is outlined with white dots. The white dots mean that the firework is selected. If we add another comet the first object becomes unselected, as indicated by the red dots (you have to hover the mouse over the Sky Field to see the unselected outline):

The second firework is added at the same position as the first, above the launch caret. The angle of the trajectory, however, is varied so that the two fireworks don’t lie on top of each other. The amount of variation depends on the firework’s definition.

You can select a firework by clicking anywhere along its trajectory. We’ll talk more about selection when we get to the Modifying a Firework section.

**Drag and Drop**

When you drag and drop an icon, you get to control the firework’s launch point and its height (if you’re a real-world designer, this probably isn’t what you want—see the Note for the Real-World Designer, below). As you drag the icon out of the Inventory, the launch caret follows the mouse. When you drop the icon, the firework’s launch point drops to the caret, and its target point is wherever you let go of the mouse. However, this is only true for shells and comets; for the other firework types, the height is always controlled by the caliber of the mortar (you can adjust it by hand, later).

The illustrations, below, show the caret as we drag a shell, and the placement of the launch and target points when we drop. (Note that the icon itself doesn’t actually appear under the mouse as you drag it.)
Note for the Real-World Designer: Obeying the Caliber

If you’re choreographing a real-world show, you want the physics of the fireworks to obey the caliber of the mortar—when you drag-and-drop an object, you don’t want the drop point to define the placement of the target point. To place the firework so its target point is placed according to the firework’s caliber, press the **SHIFT** key before you drop.

Deleting Fireworks

To delete a firework, you first must select it and then hit the **DELETE** key (not the **BACKSPACE** key). You can also delete a firework by selecting it and choosing the **Edit > Delete** option.

If you want to delete all the fireworks in your show, choose the **Edit > Select All** option and hit **DELETE** (or choose **Edit > Delete**).
Launch Positions: The Basics

Rather than drop you fireworks randomly along the launch line, you can add them to specific launch positions. A launch position is a pre-defined location along the launch line that acts as a “magnetic cradle” for the fireworks that you add into the scene. If you reposition the launch position, all of the fireworks that have been added to it move as a group.

If you’re a real-world designer you’ll probably use launch positions exclusively (as opposed to dropping fireworks into undefined locations on the launch line). Moreover, you’ll probably define all of your launch positions first, before you start adding fireworks.

This chapter looks at the basic elements of launch positions. A later chapter, Real-World Show Design looks at move advanced topics, such as how to use launch positions to assign modules and firing pins.

Creating a Launch Position

To create a launch position, select the Edit > Add launch position menu item:

A launch position marker will appear in the center of the launch line:
If we zoom in on the marker, we see a caret sitting in the “cradle”. This means that the launch position is selected. Here’s a selected an unselected launch position:

When you click an icon in the firework Inventory, the firework is automatically added to the currently-selected launch position.

You can also add a firework to a launch position by dragging the firework near the launch position marker. As you drag the firework near the marker, the firework’s launch point caret “snaps to” the launch position marker (that’s the “magnetic” aspect). When you drop, the firework’s launch point falls into the launch position, as shown below:

When you drag a launch position, the fireworks that it cradles move with it.

**Deleting Fireworks and Launch Positions**

To delete a launch position, hover the mouse over it (it will “light up”), hold down the **CONTROL** key, and right-click. Launch positions aren’t affected by the **Edit > Delete** menu item.

When you delete a launch position, the fireworks it contains remain on the screen.
Adding Fireworks in Time

So far, we’ve only discussed how to add a firework in space along the launch line. A firework’s position in time is just as important. The rule for adding a firework in time is simple: It’s placed at the current position of the Playhead. However, there’s a wrinkle, here:

- For shells, the event that’s dropped onto the Playhead (when the shell is added) is the burst.
- For all other fireworks, it’s the launch.

In the *UI Layout* chapter, we mentioned that a firework is represented as a blip on the Timeline. There’s actually more to it than that. If we zoom into the Timeline, you’ll see that the blip leaves a trail. When we add a shell, the trail looks like this:

The blip (the burst, for a shell) is aligned with the Playhead. The trail leading up to the blip shows the duration of the launch; the trail to the right is the fall off.

For comets, fountains, and mines, the burst (essentially) coincides with the launch point:

**Adding Fireworks as the Playhead Is Moving**

Our simple rule of adding a firework at the Playhead doesn’t mean that the Playhead has to be sitting still. Another nice feature of FINALE Fireworks is that you can start the Playhead moving and add fireworks as it travels along the Timeline.

To add a firework while the Playhead is moving, you use the same methods that were previously described: Click a firework icon, or drag-and-drop the icon into the Sky Field. By default, the firework’s “launch moment” is added to the scene—when you click or drop, the firework is added and immediately launched. In
some cases, this might not be what you want. Most notably, if you’re adding fireworks as you play your show in order to coordinate bursts with specific moments in your soundtrack, you don’t want the fireworks to be added at their launch moments, you want a “click-means-burst” effect. To do this, hold down the \texttt{SHIFT} key when you click (or drop). The firework will be added at its “burst moment”.

\section*{Modifying a Firework}

You can modify a firework you’ve placed in the scene by…

\begin{itemize}
  \item moving its launch point,
  \item bending or stretching its target point,
  \item and moving it in time.
\end{itemize}

All three modifications are performed by grabbing some part of the firework and dragging the mouse. But before you do any of this, you have to select the firework.

\section*{Making a Selection}

To select a firework, you simply click anywhere along its trail in the Sky Field or on its blip on the Timeline. As you hover over the firework, its outline and blip will glow red. When you click, the glow changes to white. Here we see the effect as you approach, hover over, and then click on the firework:
You can expand the selection by `SHIFT`-clicking on other fireworks. In the illustration, below, we’ve selected two of the three shells in the scene:

`SHIFT`-clicking a selected firework will remove it from the selection.

**Moving in Space**

Once you’ve made your selection, you can move the selected fireworks’ launch points or target points. To move the launch, mouse down anywhere along the trajectory of a selected firework (this won’t change the selection) and drag. All selected fireworks move together. As you drag, a “measuring stick” appears that shows you the distance from the center of the screen to the launch point of whichever firework you clicked on. Here, we drag our selection to the left:
To bend or stretch the target points, click within the “target circle” at the top of the firework and drag. You can drag in any direction; again, the target points of all selected fireworks move in concert while the launch points remain where they are:

![Fireworks in Time](image)

When you move the target point, a measuring stick (not shown in the illustration) shows you the height and angle of the target. By default, you can only move the targets to specific spots in the Sky Field—the targets “snap to” and invisible grid. If you want to smoothly adjust the targets, hold down the **SHIFT** key as you drag.

**Moving in Time**

Moving a firework in time is similar to moving it in space: You make your selection as before, but this time you click on one of the Timeline blips and drag. Moving to the left pushes the selected fireworks backwards in time; moving to the right is into the future. As you drag, you’ll see your fireworks “perform”. For example, here we drag a green mine forward in time (to the right).
In relation to the Playhead, the mine is getting “younger”, so it appears to run backwards. If you push the firework past the Playhead, the connection to the Sky Field disappears, and a message tells you that the object is no longer visible.

**Using Launch Positions to Select Fireworks**

Launch positions aren’t just a convenient way to co-locate multiple fireworks; you can also use them as a selection tool. In the illustration, below, we see a group of mines that have been added to a launch position. Rather than selecting each firework one-by-one, you can click on the launch position marker; all of its fireworks are selected:

As mentioned earlier, if you drag the launch position marker, all of the fireworks go with it. If you want to drag the fireworks out of the launch position, click on the marker (to select the fireworks), and then click and drag by the collected launch points:
6 Working With the Timeline

This chapter looks at the tools you use to change the resolution and playback position of the Timeline, and the duration of your show.

The Timeline components are illustrated below:

The Playhead

The Playhead shows you the current temporal position in your show. There are a number of ways to position the Playhead:

- You can drag it. As you drag the Playhead, your fireworks launch and explode accordingly.
- You can jump to the beginning or end of the show by pressing the HOME and END keys, respectively.
- You can step the Playhead incrementally forward (toward the end of the show) by pressing PAGE UP (big step) or the RIGHT-ARROW key (small step).
- Similarly, PAGE DOWN and LEFT-ARROW bump the Playhead back toward the beginning of the show.
- You can start and stop the show by using the Playback Controls (which we saw in the first chapter), or by pressing the spacebar.

You can also move the Playhead by dragging the zoom slider, which we’ll describe later in this chapter.
Time Zoom Buttons

The Time Zoom Buttons let you expand and contract the Timeline. When you click the \( \text{button} \), you expand the Timeline. A smaller portion of your show is represented on the Timeline, but the Timeline blips “spread out” making it easier to select a specific firework. Here we see the before-and-after effect of zooming into the Timeline:

![Timeline zoom effect](image)

The \( \text{button} \) contracts time; more of your show is represented, but the blips are closer together.

You can also zoom in and out with the Time Zoom Slider. Which method you use for zooming is a matter of taste.

Time Display

The Time Display shows you the current time location of the Playhead (on the left) and the duration of the entire show (on the right). Both measurements are in minutes: seconds. hundredths-of-seconds:

![Time display](image)

Time Zoom Slider

The Time Zoom Slider fulfills a number of functions. It represents the portion of the show that’s displayed on the Timeline, it lets you quickly move to a different part of your show, and it lets you zoom in and out.

The track that the zoom slider sits on represents the duration of your entire show. The zoom slider itself maps to the portion that’s currently displayed in the Timeline:
You can move the Time Zoom Slider by grabbing anywhere along the middle portion and dragging. This is a great way to quickly jump to a different part of your show. Notice that when you drag, the Playhead “sticks” to one edge or the other—the Playhead can’t scroll out of view:

A particularly welcome feature of the Time Zoom Slider is that it’s resizable. Resizing the Slider is a convenient way to expand and contract the Timeline. As opposed to the zoom buttons, which zoom in and out in discrete steps, the Time Zoom Slider is continuous, letting you quickly zoom into exactly the portion of your show that you want to examine.

For example, let’s say you want to see the eight-second slice of your show that starts at exactly 90 seconds in. First, you drag the Time Zoom Slider so the section is in view:

Next, you drag the Slider’s left thumb to the right until the 1:30 mark is at the left edge of the Timeline. (Note that contracting the slider zooms in; expanding it zooms out):

Now drag the right thumb to the left:

With just three quick mouse moves, you’ve zoomed into the part of the show that you’re interested in.
Changing the Duration of Your Show

By default, all shows are two minutes long. To change the duration, select the **Edit > Set show duration** option. The **Set show duration** window will open. Type in the new duration, in seconds, and click **Set**:

![Set show duration window](image)

When you increase the duration, a blank portion is added to the end of the show. If you want to add time to the beginning of the show, increase the show’s length, select all of the fireworks, click on a firework blip on the Timeline, and drag to the right.

Be aware that the undo command (**Edit > Undo** or **CONTROL-Z**) doesn’t apply to modifications to the show’s duration.
Changing Backgrounds

You set your show’s background image by selecting an image from the Background menu. If you want to add an image of your own, select **Background > Add new background** and browsing to an image file. The file must be in this format:

- 5x3 ratio, width to height. (The images that are shipped with FINALE Fireworks are 1667 x1000 pixels). Your image will be scaled to fit the Sky Field, so it can be as small or as large as you like.
- JPEG format.

When you add your own background, the image is copied into the `backgrounds/user` directory in the FINALE Fireworks installation directory, and the name of the image is added to the Background menu. Keep in mind that the image that you see in the program is a copy of the file that you added. If you make changes to the original file, you have to re-add the image and then restart the program.

If you want to delete an image from the Background list, remove it from the `backgrounds/user` directory.
8 Saving, Opening, and Exporting your Show

To save your show, go to the File menu and select an option:

- **Save.** This will upload your show to the FINALE Fireworks website where it can be viewed by other FINALE users. The show will be rendered as a high-resolution movie and added to the website’s Show page. It takes about an hour to complete the rendering, so you won’t see it on the Show page immediately. When you select Save, you’re asked to give your show a name.

- **Save to disk.** This saves your show to your local disk as an “HBS” file. The file contains everything FINALE needs to reconstruct your show—firework placements, background image name, soundfile name, and so on. The file is text-based; if you’re intrepid, you can modify your show directly by editing the file. Note, however, that the HBS format isn’t currently documented, and you can easily corrupt the file so that FINALE won’t be able to load it.

- **Save as to disk…** This is the same as the above, but lets you save the show as a new HBS file.

The File menu’s show-opening options are:

- **Open.** When you select Open, FINALE opens a panel that lists the shows that you’ve uploaded to the FINALE website. Note that it only lists your own shows—you can’t open shows that were created by other FINALE users.

- **Open from disk…** lets you browse to and open a previously-saved HBS file.

The rest of the File items are meant for real-world designers:

- **Print Inventory Report** creates a printable list of the fireworks that you’re using in your show.

- **Print Loading Report** creates a printable mapping of fireworks-to-launch positions, and the mapping between launch positions and modules/pins.

- **Print Firing Report** creates a printable version of the firing script. It lists your fireworks in chronological order, along with their firing times and launch position information.

- The Export …Script options create firing scripts in various industry-standard formats.
9 Real-World Show Design

This chapter proposes a workflow for real-world show design and looks at the advanced aspects of FINALE that let you (the real-world designer) create and export the reports and scripts that you’ll use in the field. We’ve already looked at some of the FINALE tools that can be an aid to real-world design—launch positions, in particular. In this chapter, we’ll show you how to assign firing modules (including devices with slats) to launch positions, how to use the Firing View to view the module and pin assignments of individual fireworks, and how to export the reports that FINALE will generate for you.

Real-World Workflow

If you’re a real-world designer, your work in FINALE will probably follow this workflow.

1  Add launch positions. Define and name a set of launch positions.

2  Assign modules or slats. Assign one or more firing modules or slats to each of the launch positions.

3  Add fireworks. Add fireworks to the launch positions.

4  Assign module addresses and firing pins. Modify the fireworks’ modules and pin assignments by using the Firing View.

5  Export your show. Save your show and export it as a set of reports and a firing script.

FINALE can automate some of this work for you. Specifically, it can create and assign modules and firing pins automatically. Whether you take advantage of this automation depends, primarily, on your resources. If the number of modules that you can use isn’t an issue, and if all of the modules are the same type, then you can let FINALE automate all (or much) of the process for you. If your resources are limited, if your modules are of different types (different numbers of firing pins, specifically), or if you want to split modules across launch points, then you may need to create assignments by hand.

The next few sections will concentrate on the second and fourth steps outlined above. We’ll assume that you’ve already added launch positions to your show, a subject that we’ve already discussed. (To review, you add a launch position by choosing the Edit > Add launch position menu item.)
Assigning Modules to Launch Positions

To configure a launch position’s attributes, right-click or double-click on the launch position marker. This will bring up the **Edit position properties** panel:

![Edit position properties panel](image)

The **Name** and **Distance**... settings are provided as a convenience. The information is reproduced in some of the reports, but it has no technical significance for FINALE. The significant control, here, is the **Add module or slit** link. You can either add modules/slats to the launch point yourself or let FINALE add them for you.

When FINALE adds a module, it creates a generic module with these characteristics:

- **Module type**: “Generic32”. The type is the name of the device, used both as a convenience for the user in the printed reports and as information to FINALE so consideration can be made for the specific features or constraints of different types of modules. For example, the type “m156” tells FINALE that you’re using an ATF m156. In this case, FINALE will adjust its assignment algorithm (and possibly move fireworks in time) to accommodate the characteristics of the m156 module. We’ll discuss the details, later; the point, here, is that if you’re using an ATF m156, you may want to add a module if only to assign the proper type.

- **Address**: Starts with 1 and increases monotonically as more modules are needed.

- **First pin #**: Starts with 1 and increases until the **No. of pins** has been reached.

- **No. of pins**: 32

- **Launches/pin**: 1. This attribute lets you declare the number of e-matches that are assigned to each pin, thus letting you economize your pin assignments. If you set the value to be greater than 1, FINALE will automatically assign simultaneous fireworks to the same pin until the **Launches/pin** setting is reached.
If these characteristics match your system, then you can let FINALE automate everything for you—you don’t need to add a module/slat to the launch position. However, if you need to modify the settings, click the **Add module or slat** link. This will add a new entry to the table in the middle of the panel:

![Edit position properties](image)

By adding a single module, you can re-define the default settings that FINALE will use when it creates new modules and makes pin assignments. If you’re using different types of modules at the same launch point, add and define more modules as needed. If you assign more fireworks to the launch point then are accommodated by the modules you’ve added, FINALE will automatically create modules that match the characteristics of the last module in the list, and will set the module’s address to the first available address value.

Bear in mind that if you want to be able to assign module addresses and firing pins to specific fireworks, you must provide an address in the form, above.

There are a lot more details to FINALE’s assignment algorithm that you should understand, but first we'll look at some examples that introduces the basic concepts, and also introduce the **Firework View**.
Full Automation

In this example, we'll add two launch positions, **PositionA** and **PositionB**. Both launch positions use the FINALE default module (no slats, 32 pins, one launch per pin, etc). We add 36 fireworks to each position (in order to get over the 32 pin limit), but in three groups each, as illustrated below:

![Image of fireworks show]

The modules and firing pins assignments are listed in the Firing View. To bring up the view, choose File > Firing View (or type **CONTROL-F**):

<table>
<thead>
<tr>
<th>Burst</th>
<th>PFT</th>
<th>Name</th>
<th>Cal</th>
<th>Ang</th>
<th>Position</th>
<th>Mod/Slat</th>
<th>Addr</th>
<th>Pin</th>
</tr>
</thead>
<tbody>
<tr>
<td>00:12:26</td>
<td>2.05</td>
<td>Red Peony 3&quot;d</td>
<td>3&quot;</td>
<td>0</td>
<td>PosA</td>
<td>Generic32</td>
<td>1</td>
<td>14</td>
</tr>
<tr>
<td>00:12:26</td>
<td>2.85</td>
<td>Red Peony 3&quot;d</td>
<td>3&quot;</td>
<td>0</td>
<td>PosA</td>
<td>Generic32</td>
<td>1</td>
<td>15</td>
</tr>
<tr>
<td>00:12:26</td>
<td>2.85</td>
<td>Red Peony 3&quot;d</td>
<td>3&quot;</td>
<td>0</td>
<td>PosA</td>
<td>Generic32</td>
<td>1</td>
<td>16</td>
</tr>
<tr>
<td>00:15:05</td>
<td>2.05</td>
<td>Red Peony 3&quot; 100Random</td>
<td>3&quot;</td>
<td>0</td>
<td>PosB</td>
<td>Generic32</td>
<td>3</td>
<td>01</td>
</tr>
<tr>
<td>00:15:05</td>
<td>2.05</td>
<td>Red Peony 3&quot; 100Random</td>
<td>3&quot;</td>
<td>0</td>
<td>PosB</td>
<td>Generic32</td>
<td>3</td>
<td>02</td>
</tr>
<tr>
<td>00:15:05</td>
<td>2.85</td>
<td>Red Peony 3&quot; 100Random</td>
<td>3&quot;</td>
<td>0</td>
<td>PosB</td>
<td>Generic32</td>
<td>3</td>
<td>03</td>
</tr>
</tbody>
</table>

The columns in the view should be reasonably self-explanatory (**PFT** means “prefire time”). We’ve scrolled forward to the point in the show between the first 16 fireworks at PosA and the first of PosB. Notice that the module addresses jump from 1 to 3 between the two modules.
If we scroll much farther forward, to the juncture between “16 more” at PosB and the “Final 4” at PosA, we’ll see that address 2 was assigned to the second module in PosA:

We should note, here, that of all the values in the table, only the Addr and Pin values are (potentially) editable—you can modify the settings that they display in order to manually configure the assignments. However, this only applies to modules that have been added manually. If we click on an Addr in the current configuration, the only option we see is auto:

We’ll look at effective manual assignment in a later example. The point, here, is that in order to edit the address and pin assignments, you must first add a module manually and assign an address to it in the Edit position properties panel.

Also, be aware that while you can continue to add fireworks and edit launch positions while the Firing View is onscreen, the changes that you make aren’t immediately reflected in the Firing View’s table. To refresh the view, you must dismiss it and then bring it up again. You can dismiss the Firing View by clicking the X in the upper right hand corner, or by (again) typing CONTROL-F.
Multiple Launches-per-Pin

In this example, we’ll edit the PosA launch position so that it supports 2 launches-per-pin. We double-click the PosA launch position to bring up the **Edit position properties** panel, add a module/slat, and set **launches/pin** to 2. However, in order to increase the number of launches per pin, we **must** assign an address. We’ll use 2. For the purposes of this example, we’re also going to set the number of pins to 1:

![Edit position properties panel](image1)

When we bring up the **Firing View** and scroll to the top of the list, we see this:

![Firing View](image2)

Even though the module only has one pin, two fireworks are assigned to each module (and to the same pin), as we wanted. Also, notice that while the address of the first module is 2, the address of the next module (which is added automatically) is 1. As mentioned earlier, when FINALE assigns module addresses automatically, it picks the first available address—and since address 1 wasn’t used, that’s the address it chose.

**Using Slats**

To add a module that contains slats, double-click a launch position to bring up the **Edit position properties** panel, click the **Add module or slat** link, and construct the address so that it contains a number and a letter. (For this example we’ve set the number of pins to 2 and the launches-per-pin to 1):

![Edit position properties panel](image3)
When you use the “numberLetter” address format, FINALE knows that you’re using slats. As you exhaust the pins on one slat, FINALE creates another for you, incrementing the letter portion of the address:

FINALE will automatically create 12 slats, with addresses that run from a to l.

**Splitting Modules Across Launch Positions**

So far, we’ve assigned all the launches from a module to a single launch position. But let’s say that you want a single module to control two groups of fireworks that are assigned to different launch positions. The first group is a set of 16 fountains that are launched 200 feet from the audience—this is the main launch position. You then run scab wire to a second group of three large, important peonies that are launched 100 feet farther back and to the right. In the field, the setup looks like this:

To simulate this in FINALE, you create two launch positions (Main and Accent) and add the fireworks:
For both launch positions, bring up the **Edit position properties** panel and add a module with the same address (we’ll use 1):

![Edit position properties panel]

By assigning the same address, you tell FINALE that the two launch positions are using the same module.

Bring up the **Firing View** and scroll to the Accent fireworks:

![Firing View panel]

Because the Accent fireworks appear later than the Main fireworks, FINALE has automatically assigned pins 17-19 to them. But let’s say that you want them to be on pins 1-3. To change the assignments, click on the pin number and select another value:
When you’re finished, the assignments look like this:

Notice that the **Accent** information is presented in bold. This means that the assignments have been manually configured. FINALE won’t alter settings that have been manually configured. Also notice that the pin assignments for **Main** have been bumped up—that’s because pins 1, 2, and 3 are no longer available for automatic assignment.

### The Firing View

We just saw an example of how to use the **Firing View** to change a pin assignment. In this section, we’ll take a closer look at the **Firing View** UI and functionality. But, first, a general principle:

- You can move your fireworks and edit launch positions while the **Firing View** is onscreen. However, the changes that you make won’t be immediately reflected in the **Firing View** list. Whenever you make a change to a firework or launch position, you should close the **Firing View** and then re-open it (by typing **CONTROL-F** twice).

### Positioning the Playhead

As mentioned earlier, the **Firing View** gives you a chronological listing of the fireworks in your show. This list will, of course, become extremely long. To jump to a specific point in the list, move the Playhead near the section that you’re interested in before you type **CONTROL-F**. The list will scroll to the chosen point and color the row of the next firework that’s scheduled to be launched. For example, here we’ve placed the Playhead just before the three peonies from our previous example:
When we bring up the **Firing View**, it scrolls to our current position and colors the next firework:

![Firing View](image)

**Re-assigning Addresses and Pins**

As you add fireworks to a launch position, FINALE automatically assigns module addresses and firing pins (as we demonstrated previously). If you want to re-assign a setting, click on the **Addr** or **Pin** value and select a value from the dropdown menu that appears.

The address values that you can select from in the **Firing View** dropdown menus are restricted to the module addresses that have been specifically assigned to *that* launch position. For example, let’s say we have two launch positions, PosA and PosB. We bring up the **Edit position properties** panel and add two module addresses to each launch position, **1/2** for PosA and **3/4** for PosB:

![Edit position properties](image)
Add some fireworks to both launch positions, bring up the **Firing View**, scroll to a PosB firework, and open the **Address** dropdown menu:

The only choices you have are 3, 4, and auto.

### Conflict Detection

The **Firing View** can help you find and resolve questionable pin conflicts. FINALE lets you assign any number of fireworks to the same pin, but warns you if the fireworks aren’t all launched at the same time. If two or more non-simultaneous fireworks are assigned to the same pin, the **Firing View** marks the conflicting fireworks in red.

In the example, below, we’ve created a **Zippers** launch position that contains a sequence of zipper effects that are launched one after another. We’ve edited the launch position to contain a single 32-pin module:

We add the zippers, bring up the **Firing View**, and set the pin number of the first firework to 1. The font changes to bold to show that the value has been manually set:
Now we set the pin for a later firework to 1, as well. Because the two fireworks aren’t launched at the same time, FINALE detects a conflict and marks the second assignment in red:

<table>
<thead>
<tr>
<th>Burst</th>
<th>PTI</th>
<th>Name</th>
<th>Cal</th>
<th>Ang</th>
<th>Position</th>
<th>Mod/Slot</th>
<th>Addr</th>
<th>Pin</th>
</tr>
</thead>
<tbody>
<tr>
<td>00:12.75</td>
<td>0.30</td>
<td>2x10Shot 1s Gd Gtr Wfp Fl Comet Zipper 6&quot;</td>
<td>6&quot;</td>
<td>0</td>
<td>sprots</td>
<td>SM32E</td>
<td>1</td>
<td>01</td>
</tr>
<tr>
<td>00:13.85</td>
<td>0.30</td>
<td>2x10Shot 1s Gd Gtr Wfp Bl Comet Zipper 6&quot;</td>
<td>6&quot;</td>
<td>0</td>
<td>sprots</td>
<td>SM32E</td>
<td>1</td>
<td>02</td>
</tr>
<tr>
<td>00:14.95</td>
<td>0.30</td>
<td>2x10Shot 1s Gd Gtr Wfp Gm Comet Zipper 6&quot;</td>
<td>6&quot;</td>
<td>0</td>
<td>sprots</td>
<td>SM32E</td>
<td>1</td>
<td>03</td>
</tr>
<tr>
<td>00:16.00</td>
<td>0.30</td>
<td>2x10Shot 1s Gd Gtr Wfp Ld Comet Zipper 6&quot;</td>
<td>6&quot;</td>
<td>0</td>
<td>sprots</td>
<td>SM32E</td>
<td>1</td>
<td>01</td>
</tr>
<tr>
<td>00:17.05</td>
<td>0.30</td>
<td>2x10Shot 1s Gd Wfp Gm Comet Zipper 6&quot;</td>
<td>6&quot;</td>
<td>0</td>
<td>sprots</td>
<td>SM32E</td>
<td>1</td>
<td>05</td>
</tr>
<tr>
<td>00:18.10</td>
<td>0.30</td>
<td>2x10Shot 1s Gd Wfp Rr Comet Zprr 6&quot;</td>
<td>6&quot;</td>
<td>0</td>
<td>sprots</td>
<td>SM32E</td>
<td>1</td>
<td>06</td>
</tr>
</tbody>
</table>

FINALE doesn’t try to correct this sort of conflict for you, it just points them out. By scanning the **Firing View**, you can easily see (and correct, if necessary) your module’s pin conflicts.
Creating Your Own Fireworks

There are two ways to create a new firework in FINALE: By editing a single firework in order to create a new effect, or by selecting a group of fireworks and saving them as a *cake*. A separate book, *Creating Your Own Fireworks*, provides the details of fireworks creation and provides a reference for the firework editing tools. In this chapter, we’ll briefly summarize the process.

**Editing a Firework**

The process of editing a firework in order to create a new effect follows this outline:

1. Select an existing firework from the Inventory, add it to the scene, and then double-click it to bring up the **Firework Editor**. The **Firework Editor** contains a set of sliders, menus, and other controls that let you modify the attributes of the firework—there’s no programming or file editing involved.

2. Use the controls in the **Firework Editor** tabs to modify the firework. (You’ll need to use the slider at the bottom of the menu to reach all of the tabs.) The changes that you make are immediately applied to the selected firework.

3. To make the changes permanent and dismiss the menu, click **Apply**. If you’re dissatisfied with what you’ve done, click **Cancel**. All of the modifications that you made will be forgotten.

4. After you’re finished with your modifications (and have clicked **Apply**), you’ll return to the normal view of your scene. To save your creation, make sure the firework is still selected and choose **Edit > Save selected firework** from the Main Menu. This will bring up the **Save Firework** panel, which lets you name your new firework and optionally share it with other FINALE users. Your saved firework will be added to your local Inventory and uploaded to the FINALE Website.
Creating a Cake

A *cake* combines as many as 200 fireworks into a single effect. The individual fireworks that you add to a cake can include the fireworks that you’ve edited, and can come from any of the firework categories—you can even create a cake by combining other cakes. The process follows this outline:

1. Add some number of fireworks to the scene.
2. *SHIFT*-click to select the desired fireworks, and then choose **Edit > Save selected fireworks as cake**. You’ll see the same **Save Firework** panel that we described earlier. Give your cake a name, make it public (or not), and click **SAVE**.
3. To find the cake you created and add an instance of it to the show, go to the **Cake** category of your inventory and look in the **My private fireworks** section.
4. You can “break apart” a cake, and thus turn it back into individual fireworks, by selecting the cake and then choosing the **Edit > Break apart** cake menu item.
5. **NOTE** If you’re going to edit a firework, you shouldn’t modify its height or angle by dragging its target point in the Sky Field. Any hand-modifications that you make will be ignored when you save your new creation.

**NOTE** If you need a cake that contains more than 200 shots, edit a firework from the **Candles** category. The candle editor lets you apply a *multishot* effect that creates multiple shots of the same firework in a timed pattern.